Evaluating DA



Playing with demo version and been trying to get DA Relativity Server working in AWS EC2. Installed Relativity Server from AMI. Have tested with SQL Server, MySQL and PostgreSQL but with no success. They are also been deployed to AWS RDS service. I manage to connect and admin all these 3 databases with SSMS, MySQL Workbench and pgAdmin4.

When making connection in Relativity Server - Admin Tool, i can’t get connection databases.

With PostgreSQL i get following error: Connection to “PostgreSQL” failed: An exception occurred on the server: failed to establish a connection to “myserver.xxxxxxx.eu-west-1.rds.amazonaws.com,5432”.

Here’s connection string:

NPGSQL.NET?Server=myserver.xxxxxxxxxx.eu-west-1.rds.amazonaws.com,5432;User ID=userid;Password=userpsswd;

With SQL Server and MySQL i get error what seemed to cause because in EC2 is not drivers installed? Do they need to install manually to EC2?

I’am completely newbie in these EC2 etc. stuff. Been previously made only desktop apps.

Are you sure you have all the rights port open, incoming on where the database is hosted and outgoing on the EC2?

Hmm, MSSQL should work out fo the box. MySQL I believe we do not deploy the driver due to licensing reasons (IIRC it is GPL, so you need a commercial license or decide how to deal with the GPLness of the license yourself, unfortunately).

My colleagues might now more on Tuesday (unfortunately Monday is a holiday for the person best suited to handle this one. My apologies for this inconvenience.



It seems that this connection string is not valid for the PostgreSQL .NET driver (however it might be valid for pgAdmin4 at the same time):

It should be (note the server name and port)


Could you say which exactly errors did you got? MS SQL drivers are a part of the .NET Framework itself.



Thanks for replying at weekend!

With MSSQL problem must have been in AWS security definitions. But i’am going to use PostgreSQL.

Now i’am able to connect PostgreSQL with pgAdmin4. When making connection from Relativity Server Admin, i now get this error:

“An exception occurred on the server: Unknown driver PSQL.NET”.

I added to connection string Port=5432:

PSQL.NET?Server Name=postgredb.xxxxxxxx.eu-west1.rds.amazonaws.com;Port=5432;UserID=xxxxxxx;Password=xxxxxxxx;

I tested MSSQL once more and got it working.

With MSSQL is same security definitions as PostgreSQL so it seems that there’s some problem with PostgreSQL driver.

I test now DA with MSSQL and after it make decision of purchase and what DB to use. This your support at weekend was very convincing and affected positively very much to my purchase decision.

Profile name in the connection string should be NPGSQL.NET?..., not PGSQL.NET?...

IIRC you need a special prefix for MSSQL in AWS, if you use the Express version. I just tried to check what we use, but it seems we’re on full now :(.

As I recall, rather than the “\SQLEXPRESS” suffix, it was a variations, such as \EC2SQLEXPRESS or the like. Unfortunately I have a hard time finding uniting about this on Google right now.

Yeah, it sounds like the driver is actually missing :(. We really should be creating updated AMIs for the latest Relativity server anyways, when we do, I’ll make sure it gets included (unfortunately, I don’t have the login for the finished AMI (for security reasons, we destroy/discard the key when done), but if you want, you can follow these steps to install (latest) Relativity on a fresh Linux EC2 instance:


Happy to hear!


Yes, now i can connect PostgreSQL in AWS. Driver name is NPGSQL.NET.

Connection string what builder makes is “Server Name=xxxx”. I get an error but fixed it manually “Server=xxxx”.

Connection builder still didn’t showed databases what are in server so added it also manually: “Database=demo;”

EDIT: MSSQL Express is what i now use, seems to be working fine.

Hmm, is that the Connection Builder in Schema Modeler for Windows?


Schema Modeler. There’s also that “wrong” PostgreSQL driver available, real one also :slight_smile:

I see NPGSQL.NET and PSQL.NET (not PG, mind you, just P, which is Pervasive, not PostreSQL).

As for Server Name, I get “NPGSQL.NET?Server=localhost;”. What am I missing, steps wise?

I have accidentally picked Pervasive driver and maybe in Pervasive connection string server is “Server name” and not “Server” like it’s in PostgreSQL. I manually changed that in connection string after error message.

Pervasive and PostgreSQL drivers look similar, i have learned my lesson now :slight_smile:

EDIT: Tested, in Pervasive conn string server is “Server name=xxxx”

1 Like