Failed to verify code signature: no code signature found

oxygene

(Carlos Frias) #1

Water
Elements 10.0.0.2337

I can not debug any application on physical iPhones (XS, SE)
The same behavior occurs in Visual Studio 2015 Community.

With Fire it works perfectly.

Attached solution for test and build log.
AppBorrame.rar (1.1 MB)
BuildLog.txt (41.5 KB)


(Carlos Frias) #2

Can someone help me with this.


(marc hoffman) #3

Carlos,

my apologies for the delay, somehow you original message slipped by me.

The most likely explanation for this error is a mismatch between the certificate, the profile (and the devices listed in the profile) and the actual device you are running on. Looking at the device log in Console.app on the Mac might show a more detailed error message that explains it better than th generic error code that gets reported to Water during deploy.


(Carlos Frias) #4

Well, the app is loaded into the device with Fire, so the profiles should be alright, if not, apple wouldn’t let me install.

So the problem must be somewhere else in Visual Studio and/or Water in Windows 10. I noticed something weird in Visual Studio 2017, I cannot select the “provisioning profile ID” (no options suggested), and the “provisioning profile name” shows the provisioning profile ID (not the name).

I only have one one provisioning profile and one certificate, so I can’t mismatch anything. I also tried with Xcode and this certificate and provisioning profile, which runs and debugs perfectly.

I really need your help here, I tried everything I could imagine.

Thanks in advance.


(marc hoffman) #5

Have you tried

?


(marc hoffman) #6

Also, can you goto your Mac, zip up

“/Users/Charly/Library/Application Support/RemObjects Software/EBuild/CrossBox/Clients/W7DEV17/AppBorrame-360080D03623A0321E9DD4F9CD67091DD358069F/Toffee-iOS/AppBorrame.app”

and send me that? Does that bundle have a code signature?

how about the one at

C:\Users\charly.DTRF\AppData\Local\RemObjects Software\EBuild\Obj\AppBorrame-360080D03623A0321E9DD4F9CD67091DD358069F\Debug\Toffee-iOS\Device\AppBorrame.app


(Carlos Frias) #7

Thanks, Mark.

I think that it have. But I’m not an expertise in Apple tecnologies. I’m sure it’s easier for you.

AppBorrame.app.rar (524.1 KB)


(Carlos Frias) #8

Log from crossboxhekper process:

22:49:59.585273 +0200 crossboxhelper AMDeviceTransferApplication (thread 0x7fff8a0c5380): ENTRY
22:49:59.594862 +0200 crossboxhelper nuke_path (thread 0x7fff8a0c5380): AFCRemovePath of 'PublicStaging/AppBorrame.app' returned 8
22:50:00.041032 +0200 crossboxhelper AMDeviceInstallApplication (thread 0x7fff8a0c5380): ENTRY
22:50:00.094345 +0200 crossboxhelper AMDErrorForMobileInstallationCallbackDict (thread 0x7fff8a0c5380): GOT AN ERROR 0xe800003a
22:50:00.094474 +0200 crossboxhelper perform_command (thread 0x7fff8a0c5380): There was an error communicating with the service agent: 0xe800801c
22:50:00.094555 +0200 crossboxhelper AMDeviceSecureInstallApplication (thread 0x7fff8a0c5380): Old style install failed for (PublicStaging/AppBorrame.app)
22:50:00.094631 +0200 crossboxhelper AMDeviceSecureInstallApplication (thread 0x7fff8a0c5380): Could not install package on device: e800801c

Device log:

Device Log.rar (3.1 KB)

If you need something else do not hesitate to ask me.


(marc hoffman) #9

Curious. I see a CodeSignature folder in the bundle, but RB App Checker Lite (free on the Mac App Store, highly recommended tool) claims:

Evaluating the application “AppBorrame.app”.

The application is unsigned. 
	Executable code for arm64 has the UUID “088ED051-D597-3566-A41A-E841F29F9A08”.


A development profile is present: “WildcarDevelopment”. 
	UUID: “2b06daf7-e36c-4dbf-9605-b2ae414d0f60”.
	Created on Oct 22, 2018.
	Will expire on Oct 22, 2019.
	The profile specifies the application “Xcode iOS Wildcard App ID” (8YMSTWPHDJ).
	The profile specifies the team “Encuesta Facil SL” (8YMSTWPHDJ).
	The profile matches the application's Team ID ().
	There are 4 provisioned devices. 
	The profile was signed by 3 certificates. 
	The profile may be used by one developer:
		Developer Certificate “iPhone Developer: Carlos Frias Martinez (WBDX5VC4HG)”. 

The application is not sandboxed.

The application is quarantined. 

No auxiliary executables have been found.

the valid art from the Device log is

22:50:00.112721 +0200	mobile_installation_proxy	0x16d3c3000 handle_install: Installation failed: Error Domain=MIInstallerErrorDomain Code=13 "Failed to verify code signature of /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.12qBu6/extracted/AppBorrame.app : 0xe800801c (No code signature found.)" UserInfo={LibMISErrorNumber=-402620388, LegacyErrorString=ApplicationVerificationFailed, SourceFileLine=199, FunctionName=+[MICodeSigningVerifier _validateSignatureAndCopyInfoForURL:withOptions:error:], NSLocalizedDescription=Failed to verify code signature of /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.12qBu6/extracted/AppBorrame.app : 0xe800801c (No code signature found.)}

and that seems to match. somehow, this code signature is broken.

This is the exact same project that deployed fine when you built it in Fire (as per your the thread, where the debugger crashed), correct?

Can you do me. favor and try the following steps:

  • do a Clean

  • delete /Users/Charly/Library/Application Support/RemObjects Software/EBuild/CrossBox/Clients/W7DEV17/ on your Mac

  • delete C:\Users\charly.DTRF\AppData\Local\RemObjects Software\EBuild\Obj\AppBorrame-360080D03623A0321E9DD4F9CD67091DD358069F on Windows

  • build (don’t run the app)

  • zip up /Users/Charly/Library/Application Support/RemObjects Software/EBuild/CrossBox/Clients/W7DEV17/AppBorrame-360080D03623A0321E9DD4F9CD67091DD358069F/Toffee-iOS/AppBorrame.app/

  • zip up C:\Users\charly.DTRF\AppData\Local\RemObjects Software\EBuild\Obj\AppBorrame-360080D03623A0321E9DD4F9CD67091DD358069F\Debug\Toffee-iOS\Device\AppBorrame.app

THEN:

  • run

  • zip up /Users/Charly/Library/Application Support/RemObjects Software/EBuild/CrossBox/Clients/W7DEV17/AppBorrame-360080D03623A0321E9DD4F9CD67091DD358069F/Toffee-iOS/AppBorrame.app/ (again)

and send me all three zips, named in a way so I know which is which.

the first would be the app, as signed on the Mac
the second is that same app, downloaded to Windows
the third on would be the app (possibly) rue-loaded to your Mac to debug it

I wanna see which phase breaks the sig (and how).

thanx!


(Carlos Frias) #10

Yes, it is the same project. But it happens with every project.

I checked Fire signs the App (usingRB App Checker Lite, thanks), but the problem in the other thread persist.


(Carlos Frias) #11

AppBorrame.app.rar (524.1 KB)


(Carlos Frias) #12

AppBorrame.app.rar (524.2 KB)


(Carlos Frias) #13

AppBorrame.app.rar (524.1 KB)


(Carlos Frias) #14

It seems to me that the three are identical.


(marc hoffman) #15

Yep. the first one is already not signed properly. weird…


(marc hoffman) #16

Ok, found the problem. It seems that access to the key chain can be restricted when calling code sign via SSH, as CrossBox does. There should be an error in the log, such as

           > codesign: errSecInternalComponent

unfortunately, EBuild did now always recognize this as a failure (that part is fixed, it will fail the build now). I now need to research how to fix this to make kit work properly. Google has many suggestions, none of which worked cleanly for me (such as https://stackoverflow.com/questions/20205162/user-interaction-is-not-allowed-trying-to-sign-an-osx-app-using-codesign), but you might want to try them, too.


(Carlos Frias) #17

I try it later and I tell you.


(Carlos Frias) #18

I have not gotten it to work.

I attached a log where several codesign errors appear in a rebuild.

CodesingError.rar (12.5 KB)


(marc hoffman) #19

im working on a fix. it will probably involve having tor spwcify the keychain passwoed in the project settings, Windows side…


(Carlos Frias) #20

It does make sense.