Find in "Entire solution" or "Current project" does not work

Visual Studio Community 2022 17.3.0
RemObjects Elements

Ctrl+F and Ctrl+Shift+F does not work if I select “Look in” “Entire solution” or “Current project”.

If I select “Current directory”, “All open documents” or “Current document” works as expected.


Logged as bugs://E26098.

Hello Carlos,
I tried searching in a simple console app, and it works as expected with both Solution and Project. Could you please check if this problem happens with some specific project for you? Are you able to search in some simple newly created project?

I have built a console application (.net 4.8) and it does not work. I show it to you in two screenshots.

The search:

The result:

This is odd. The search is provided by VS, most probably we don’t do anything specific for it. May I ask you what happens with the same search for microsoft languages - Microsoft C# or VB? Do they provide you with proper results in Entire solution?
I also found a similar topic inthe stackoverflow where people in comments claim this bug still happens to them in VS2017 and 2019. They also provide some ways to solve it. Maybe it will help you: visual studio - Search stops working for "Entire Solution" - Stack Overflow
Please let me know if some of these helped with your problem.

Hi Viktoria,
I have the same problem with Oxygene, but not with MS C#.
So the problem should not be related to the keyboard (I don’t even have the Break or ScollLock keys on my keayboard!)

Hi Viktoria,
Just came into the error now.
Very strange:
If I select *.pas;*.xml or *.* in File types, VS finds the occurences in the xml files, but not in the pas files.
It seems that VS skips the pas files when searching…

Weird. almost as if file types have to be registered for search with VS, separately, @viktoriad?

@Patrick, if you add a .cs, a .vb and a .java file to your (Elements) project, do the cs and vb files get searched/found, and the java does not?

Trying again, it now doesn’t find the text in an xml source file!
Previously, it was in the xml files generated by the compiler (documentation).
So it seems that Find and Replace completely skips all the files in the oxygene projects.

1 Like

Works perfectly with Microsoft C#.

I have included a .cs file in an Elements Oxygene project and it does not find anything.

I have tried the opposite: in a Microsoft C# project I have included a .pas file and the search engine works without problems.

Thanks for the report. I was able to reproduce the issue with latest VS2022 update. Previous versions worked fine. It looks they moved some API between dlls which causes the problem during runtime with finding some types. I am working on the fix now.

1 Like

Great, I’m glad you have it on track because, to be honest, it’s hard to work without the “find”.

bugs://E26098 was closed as fixed.

The issue is fixed. The fix will be available in the next build. Please let me know if you have any more problems with Find in a new build.
Best regards.

1 Like

I have installed and it works perfectly.

1 Like

Happy to hear!