Fire debugging problem with XCode 15.3 and latest version of Fire (from stable channel) IOS 17.4

I upgraded Xcode to 15.3 version , my physical IPhone 12 to 17.4.1 and I can’t debug … I have last version of Fire from stable channel.
I can compile, run but running is finishing on :
[100%] InstallComplete
[100%] Installed package /Users/mateusz/inprax/IOS/Testowe/App1/Bin/Debug/iOS/
Running “/Applications/Fire” --id 00008101-001939223A80001E --debug --nolldb --noinstall --bundle /Users/mateusz/inprax/IOS/Testowe/App1/Bin/Debug/iOS/
[…] Waiting for iOS device to be connected
[…] Using 00008101-001939223A80001E (D53gAP, iPhone 12, iphoneos, arm64e, 17.4.1, 21E237) a.k.a. ‘iPhone (Mateusz)’.
------ Debug phase ------
Starting debug of 00008101-001939223A80001E (D53gAP, iPhone 12, iphoneos, arm64e, 17.4.1, 21E237) a.k.a. ‘iPhone (Mateusz)’ connected through USB…

That is all, when I run apk from iphone it is working ok but I need debugger.
Should I do something or here is a problem with XCode 15 or maybe something wrong is on my machine ? Any help appreciated…

After 20 sec I got in log info:
2024-05-06 17:03:04.397 ios-deploy[4443:70664] [ !! ] Unable to locate DeviceSupport directory with suffix ‘DeveloperDiskImage.dmg’. This probably means you don’t have Xcode installed, you will need to launch the app manually and logging output will not be shown!

I found some thread here but without solution (can’t find in XCODE DeviceSupport forlder for IOS 17 - no longer supported ???)

Why I updated to latest version because I got info from Transporter :

SDK version issue. This app was built with the iOS 16.4 SDK. Starting April 29, 2024, all iOS and iPadOS apps must be built with the iOS 17 SDK or later, included in Xcode 15 or later, in order to be uploaded to App Store Connect or submitted for distribution. (90725)

P.S. Simple app in XCode 15.3 is working normally as expected.

Best regards

Open Xcode and the Devices window, and let it download “device support” for the version of iOS on your phone.

Hi Marc, I opend but still can’t see proper folder in deviceSupport…
Should i do something more ?


Does it sow your phone and is it "ready’?ie no colored bar at the top saying “Preparing for debugging” our the like?

I don’t know how to get it … to this DeviceSupport folder :frowning:

You don’t have to. Xcode should create it, and our debugger looks for it to find the .dmg with debug symbols to mount one the device.

Your screenshot looks good. I don’t have any immediate other ideas what the problem could be, or why the device support false scant be found…

I read that Apple will change connection (using coredevice) did you hear about it (device support no longer needed) ?

so what can i do to run debug mode ?

I need it…

Do you know about it ?

No :frowning: it’s specific to your exact hardware and software version (down to the build number)

So I can’t debug because Apple change the way they connect to physical device ?

With iOS 17+, we are using a new device stack (CoreDevice) to communicate with devices. With this new device stack, there is one DDI per platform (as opposed to per OS release). This same device stack will be shared across all versions of Xcode on your system, and installing a newer version of Xcode will update CoreDevice and its DDIs (just like how CoreSimulator is updated, if you are familiar with that).

Hmm. looks like apple broke how this works :(. I’ll need to log an issue and investigate.


Logged as bugs://E26948.

Damn… Apple and Google have broken all what has been working so far

1 Like

On then plus side, it looks like Apple has an official command line tool we can use to work with excess now, devicectl. This will be some work to switch over to, but in the long run should work more reliably than the third-party iOS-deploy tool that essentially relied on documented APIs.

How long ? I need to make some changes in my app but without debugging it is…hard → and i have to write another one - should i migrate to XCode ?
I had such a problem with google as you remember or not with AppCompat library and I have to rewrite apk in AS :frowning:

I have no idea.

NSLog is your friend for debugging w/o a debugger ;).

I thought @Diego_Navarro solved these issues. Can you touch base with him on a new thread WRT the issues you’re seeing with Android?

I used as You sad shared library and rewrited apk in AS (it is working fine)

Is it ideal, no. Is it fine for some emergency debugging? It should be. TBH 90% of my own debbugging is based on logging stuff.