FireMonkey plugin issue

(Xie Fang) #1

In FireMonkey Sample project, the firemonkey plugin edit control can’t select text, and window focus incorrect sometime.

(RemObjects) #2

Thanks, logged as bugs://76562

(RemObjects) #3

bugs://76562 got closed with status fixed.

(EvgenyK) #4

pls update uHYVisualPlugin_FMX as

procedure THYFMXVisualPlugin.MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Single);
  if Focused <> nil then begin

and rebuild Hydra_FMX package

(EvgenyK) #5

by other hand, you can install the latest RTM (RemObjects Hydra -

(Xie Fang) #6

Thank you.

But, when focus in edit control, host window will lost active window state. it is bug?

(EvgenyK) #7

I’ll investigate this case.

(RemObjects) #8

Thanks, logged as bugs://76788

(Xie Fang) #9

When will the problem be solved? thanks.

(EvgenyK) #10

I’m sorry, it is still on our issues’ table. I’ve increased priority for it

(Xie Fang) #11

I very much hope to be able to use FireMonkey based plug-ins ASAP. Thank you very much.

(Xie Fang) #12

When will the problem be solved? ask again?

(EvgenyK) #13

I can confirm - when an edit control receives focus, form loses active window state. this case isn’t solved.

(Xie Fang) #14

I need a solution ASAP. thanks.

(EvgenyK) #15

Unfortunately this behavior is caused by the way FireMonkey works as well as the way its Hydra integration works. It is hardly possible (if possible at all) to change it without full re-implementation of the FMX Hydra integration .

(RemObjects) #16

bugs://76788 got closed with status fixed.

(Xie Fang) #17

How to upgrade it? Thanks.

(EvgenyK) #18

RTM was already created and will be published this week

(Xie Fang) #19

Thank you very much.

(Xie Fang) #20

This bug was fixed, but still can’t select any text in textbox control.