Getting License error when trying to open RODL file

We have licenses for remobjects sdk 10.0. We also have some older projects that do not use code first server yet. In that project I am trying to open the RODL file to add server functionality. When I do that I do not get the portal but a License file expired prompt. If I launch the license manager I see that I have a full license for Remobjects SDK for .NET version 10.0 (Beta: true, final:true) And the subcription end date is not until 2021-01-01.

What is the issue here?

I don’t have an answer to why it happens but a workaround for me has been to use the license manager to download the licenses from the Download Licenses button even though I may have downloaded the license file earlier.

It seems to be a problem if the license file download occurs before the installer is ran if I remember correctly.

Try to redownload the license file from and to import it once asked by the Service Builder

Sorry for the inconvenience

No luck so far. I’ve tried redownloading the licenses and importing them. Also tried to download them from the licanse manager.
It is only opening the service builder from visual studio. The main functionality is still working.

Could you upload contents of the c:\Users\######\AppData\Roaming\RemObjects Software\Licenses folder to support@ and specify exact RO SDK version you are using?

Thanks in advance


better to use support@ if you want to share private things

Ok, mail has been sent to support@