Headerimporter: Train cant find the RemObjects.Train project


I am using your wonderful train tool and I have closely got used to except, he gives me this nasty error and I dont know, do I anything wrong or is it a potencial bug, for that I need your help.


Best regards


hmm. is RemObjects.Train.dll located next to Train.exe? of not, there’s your problem :wink:

yes it is, see pic :smiley:


Thats how I do it:

  1. start the cmd
  2. cd C:\Users\phoenix\train
  3. enter Train.exe cd C:\Users\phoenix\train\build.train

Then an error occurs: “MSB1009: The project file wasnt found” Build faild

Ok, thats a different error now though? it sounds like it can’t find the .SLN or one of the .elements files in it?

Hmm, what do you suggest me^^

I have no other Idea what to try out^^

I have a hard time understanding what your problem is, TBH. In your first screenshot, Train can’t find one of the dlls it needs to run. In the second screenshot, that problem seems to be solved, but MSBuild can’t find the project fie you are building. I’m nit sure what you’re asking here…

Ok, the first one was solved, yes, it was created by myself, ok.

But the second one, is new and I ACTUALLY think that I ve done all right so far, as I described here:

Is this process right, or what am I missing, that he cant find the .elements?

Train.sln , Train.elements and build.train are in the train-folder, the train.exe is in the /bin/Debug folder

What do I do wrong here? He misses the file but all nessecary files I have !described are there?


I have no idea :wink:

Thats pretty sad…

I desperately need some C-files…

I don’t even understand what you are trying to do here…

I want to make use of Headerimporter, and as described in the tutorial, i need the train-script, right?

and that doesnt work, what are u struggles in understanding me?

How do you use it then, can u provide me an light example?


you do not need to use Train to import .h files…
you can create a .json file that you can pass into the HeaderImporter tool.
I attached an example file that I used to import .h filesCortexM4FXImport.json (3.2 KB)

hi, Jesus, I misunderstood this so^^

Thanks, and what actually do I have to correct for my system, just the Targetstring?

Ofc, all of the files I need are just 3 .h files

The platform I changed to Windows

I don’t really know those details, it took me a while to get this working for ARM. Maybe someone else can give you those details…

1 Like

Yes, I see I have to investigate a lot into this, but still thanks!