How to use my named employee license on my personal PC

I installed Delphi 11 and RemObjects Data Abstract + Relativity Server on my company laptop, but it broke. In the meantime, I downloaded my repository from the company server and installed everything on my personal notebook to continue working.
On this PC I was using a trial version of RemObjects DA, and when I compile a Windows Service using it, it is created as a Trial DA. I cannot run the service.
My company email is not a Microsoft account, so that it is a little difficult to create a new profile just for running Delphi.
Is there any solution?

Sorry, I discovered RemObjects.Everwood.LicenseManager.exe, so I just downloaded the licenses and replaced the older trial licenses with the new license.
Unfortunately, I didn’t know about this program, there is no shortcut on the RemObjects menu, nothing…

1 Like

While RemObjects.Everwood.LicenseManager.exe works, it’s really deprecated, which is why we don’t reference it from the Start Menu anymore. The products should all ask you to login in and download your licenses for you when used form the IDE. It’s strange that this did not happen…


When I installed this version, I had to provide my information (username and password) to enable RemObjects Data Abstract on the IDE.

But the compiled application said that it was still using a trial version of RemObjects SDK.

Using the License Manager, I was able to download the correct licenses.

In the meantime, I created a desktop application to test most of the Windows service from the IDE.

But once I test everything, I will need the licensed executable.

License Manager was the solution.



Ah! note that for our library products, trial and full license ship different binaries (and source code, for full), because you cannot really do license management on source code.SO logging in and getting your license activates your products license, but you’re still building agains the trial .dcu files of the library. You’ll need to install the non-trial version of the product to get the source and./or non-trial .dcu files.

My apologies for that confusion and the inconvenience.


I reinstalled everything related to RemObjects Data Abstract.

I used License Manager to download the company license assigned to me (

When I started Delphi 11 Alexandria, I didn’t get any request to enter my username/password (probably because I used a trial before).

After rebuilding one of the programs using RemObjects Data Abstract (connected to a local Relativity Server and Microsoft SQL Server Express database), I got the same error as before:


It is a big issue for me because this is a test for the tasks I execute in a Windows service, which will run on a server.

How can I fix this?

David Izada Rodriguez

If you logged in before, that will persist and you should be logged in already yes.

I cannot see this image, but I assume ti still says you are using a trial version? If so, can you make sure you installed the non-trial setup of the product? also, can you check your search oaths to see which versions of the library .pas or .dcu files you are building against?


Can you specify what installer you have used, pls?

  • RemObjects Data Abstract for Delphi, Server Edition -
  • RemObjects Data Abstract for Delphi, Server Edition - - Trial.exe

have you logged to personal cabinet and downloaded the installer from it?


The trial version I used was older. I worked on another project for a few months.

Once the company bought a license for me, I installed the Server Edition build 1559.

When I started having issues, I uninstalled everything and installed the Server Edition 1569.

Everything works fine from the IDE, but the build is using some old DCUs from the trial version of the SDK.

My library paths have the correct information:

But the browsing paths are incorrect!

This path is correct: C:\Program Files (x86)\RemObjects Software\Data Abstract for Delphi\Source

This path was missing: C:\Program Files (x86)\RemObjects Software\RemObjects SDK for Delphi\Source

That is the reason, it is not building the licensed DCUs for RemObjects SDK.

I rebuilt the project, and the issue is resolved.



We have some useful commands:

  • C:\Program Files (x86)\RemObjects Software\Build\install_DA.cmd - rebuilds all .dcu/.bpl
  • C:\Program Files (x86)\RemObjects Software\Build\register_DA.cmd - restores missed paths in IDE



In the past, the data module generated by DA created all tables with datasources, and the TDALocalCommand for the stored procedures.

I manually added a TDALocalCommand for a procedure I have in my MSSQL database, but it is reporting an error:

“Class factory for interface RemoteService not found”

My code using the command is:


cmdGetLastMessageID.Execute(‘GetLastMessageID’, nil, outParams);

if Assigned(outParams) then


for var i : integer := 0 to outParams.Count - 1 do

if outParams[i].Name = ‘MessageID’ then





The data module connects correctly to Relativity Server, and to the MSSQL database. I can get the design-time data.

Do I need to use a different component?



TDARemoteCommand is designed for client-side and TDALocalCommand for server-side.

if your data module connects to Relativity Server you should use TDARemoteCommand

both components have almost the same methods and properties so you can use your code with TDARemoteCommand w/o any changes.


4 posts were split to a new topic: Population of input parameters of TDARemoteCommand