Installation failure on Dephi IDE


(mahmoud EL SAWAH) #1

Hi

I tried to install the demo version of RemObject for Delphi but the integration with Delphi fails with the bellow message:

lcdnmaicfmjfnpdd

I had to uninstall it to restart the Delphi IDE - Let me know if you have a fix for it

The uninstall also did not left a clean situation behind:

gdooogcennlpgcjd


(EvgenyK) #2

Hi,

Our trial versions are required the latest versions of Delphi. this is trial limitation.
D25 packages require Delphi 10.2.3


(mahmoud EL SAWAH) #3

So if I understood correctly I buy DataAbstract and then when I want to modify my server to include DataAbstract side by side with datasnap I cannot !!!
That’s not really the customer experience I was expecting…


(EvgenyK) #4

I’m sorry, can you rephrase your question?
what problems you have with DataAbstract and datasnap?


(Michael Thuma) #5

In order to use the trial version of Data Abstract you need the latest version Delphi installed. The commercial version does include support for all other versions too since it’s compiled from source if I remember correctly.

The simple reason is that due to the fragmentation of Delphi versions installed the installers simply grow too big. That’s my guess. Remember the days when Delphi versions were shipped twice a year. From the perspective of Remobjects technology all these version did offer simply the same. Pretty much the same counted for most of the Delphi developers.

So far I can just tell you that setting up a latest Delphi in a separate box and installing RAD Studio together with Data Abstract does make sense. If you are going to evaluate Data Abstract doing so is worth the effort or simply ask Salem Saberhagen aka. Evgeny the black cat.


(mahmoud EL SAWAH) #6

I see, as i bought Data Abstract, i saw this note on the downloads:" Note: Every download of Data Abstract includes Remoting SDK ."
does that means that as i have bought Data Abstract i already have the paid version of Remoting SDK ?


(EvgenyK) #7

Remoting SDK is a part of Data Abstract so you don’t need to buy it separately.


(mahmoud EL SAWAH) #8

yeah but to perform the procedure described here Connecting DataAbstract to a Datasnap server
i need to have Remobject SDK, no?


(EvgenyK) #9

we have renamed RemObject SDK with Remoting SDK recently.
so you already have all that you need.


(mahmoud EL SAWAH) #10

Great thanks