Interface Import Java to Delphi

This issue occuring now for a few days, i dont have any idea or solution yet.
I started toying with netbeans for a few days in order to test switching from Eclipse.
After finishing my research I installed last version of Eclipse Eclipse IDE for Enterprise Java Developers - 2020-03. The issue occurs in Hydra Version 6.2.101.1239 and also in Version 6.2.101.1243. I guess it will also happen in Stable version (untested since importer had a bug with code generator in delphi).

I use OpenJDK from https://jdk.java.net/13/ for running eclipse. As JRE-Compiler in Eclipse i tried JDK13.0.2 64-Bit, JRE 8.0.241 32-Bit (in order to test if its the issue). Hydra in Delphi points towards JRE 8.0.241 32-Bit. I´ve written a new test plugin in order to test some performance with json requests but also tried to import the previous displayed Java Plugin this threads :



So i believe my written sample should be working.

Any ideas?

Hi,

can you send your plugin to support@ for investigation, pls?
you can remove all code from java methods

Good morning @EvgenyK,

You still should have that mail from my other post. If you already deleted it, i can resend it again.
There were no special code in my new plugin aside that i added a function

public string performRequest(String Value){
return “Test”;
}

I were toying with building JSON based Requests and send them towards Plugin.

Hi,

I’ve added performRequest method and Java importer works w/o any issues.
it generated code like

function TPluginImplementationWrapper.PerformRequest(arg0: UnicodeString): UnicodeString;
var
  lmethodId: JMethodID;
  largs: JValueDynArray;
begin
  lmethodId := Self.JVM.Reflection.GetMethodId(Self.ClassID, 'performRequest', '(Ljava/lang/String;)Ljava/lang/String;');
  System.SetLength(largs, 1);
  largs[0] := Self.JVM.ValueConverter.ConvertFromString(arg0);
  result := Self.JVM.ValueConverter.ConvertToString(Self.JVM.Reflection.CallObjectMethod(Self.InstanceID, lmethodId, largs));
  exit;
end;

I can attach .jar here or sent it to you via PM.

Send it to me via pn please. I like to test if it works on my side then (then i need to clarify whats wrong on code). If it doesnt work it could be something special in the envirement. Do i need Visual Studio installed? I uninstalled it last week.

done.
you don’t need VS