Invalid pointer operation after upgrade 1567


I have an error after upgrade to 0.1567. My procedures as below:

  1. Create new table in MSSQL
  2. Add new table to DA Server.
  3. Add new TDAMemDataTable in client and click “Retrieve DataTable Schema”.
  4. Set “Active” to “True”. Then it has the following error.


I tried to set “Active” to “True” in previous TDAMemDataTable that without this error. I also tried to rollback 1561 and recompile DAServer and client. It still has same problem. Finally, I need to remove new table in DAServer and then add it again under 1561. Then problem is gone. I guess 1567 DAServer side has problem.



hmm, I can’t reproduce this issue.

My actions:

  • create a new Client and New custom Data Abstract Server from wizard
  • removed all tables from client-side
  • RDA->Create DataTables…
  • table.Active = True

everything works

Also your scenario works as expected: drop TDAMemDataTable , assign RDA and LogicalName, RDA->Retrieve Datatables, table.Active = True

Can you reproduce this issue with std PCTrade-SQLite connection?

Your actions are different with my actions. Mainly is my action that is not create new project. I clarify my steps as below:

  1. Using existing project that are using 1561 version in DAServer & RDA
  2. Upgrade version from 1561 to 1567.
  3. Create new table in SQL server and then add into DAServer.
  4. Add new TDAMemDataTable in client and click “Retrieve DataTable Schema”.
  5. Set Active to True.

I already rollback to 1561 and problem is gone. I will try to reproduce with std PCTrade-SQLite connection if I have time.