Island Debugger jumps MeaningLESSly

Elements Build 2485, Island/Windows, Mixed Languages (Oxygene and C#)

@ck @mh
I really wish I could have a simpler Test project, but I just couldn’t.

It is a EUnit/Island test project - the Test itself could finish successfully with all test cases.

But when I tried to step into the highlighted line in the Figure below, the DEBUGGER go bananas and jumps here and there.

To replicate it, clone the repository at

  • Put a break point at line 106 of CoreClassesTest.cs

  • run ./Tests/TensorFlow.Island.Tests.sln,

Apology for not able to generate a simpler case, I tried but I cannot replicate with a simple case.

just to be clear; this is debug, not release right?

Yes. DEBUG config

Build 2485

Mixes C# and Oxygene.
It seems to me the call stack was messed up when a C# method calls another Oxygene method which calls another C# method … all these methods are part of the same partial class implemented in Oxygene (OpsExtra.pas) and C# (OpsGenetated.cs) separately.

Thanks, logged as bugs://83993


I cleaned up the Test Project and made a small one to replicate the issue. The test project can be downloaded here:

Hopefull this will make it convenient for you.

1 Like

Sorry for the nagging. I understand you guys are busy with a lot of stuff on the plate.

Just check if this issue has been replicated on your side, or a possible fix coming on the way?

I cannot continue with my project since I am not able to use the debugger for my mixed language project - so a fix would be really appreciated.

I’ve bumped the priority up.

1 Like

I just found that this was actually fixed with 84051: Island Debugger shows wrong file when steps into partial class method (Carlo Kok 20200311-131250)

Thank you very much!!

1 Like

bugs://84051 got closed with status fixed.

bugs://83993 got closed with status fixed.