Island.Shared github project - Ebuild: Unknown Identifier

When I Build the project (Island.shared) out of sudden, the compiler throws errors, like he cant find a method which is declared in a unit scope, and is being called in an inherited class, see image as an example:

We’ll need some more details for this. What constitutes “all of a sudden” — does it mean the project buyout ok for you before, and something changed? if so, what?

Obviously, the project builds for us (I just double-checked here, myself), but we couldn’t ship a new build of Elements if it failed, as Island RTL gets built as part of creating the build :).

But also, IslandConsole_Test isn’t our project, AFAIK. what exactly are you trying to accomplish here? Are you using the Island.Shared.elements project directly from your app? If so, don’t.

scratch the out of sudden, it just doesnt compile :smiley:

i thought of that ofc, otherwise you would have probably multiple reports incoming why all is red haha.

Can you give me a small guide somehow how to test my changes in a, console project? But first I need to get rid of these compiler errors, he is saying for IntPtr for instance, “Uknown type” and multiple references and such… im doing ofc smth wrong ofc, but dont know exactly what.

You’re making changes to Island RTL itself that you wanna test?

Two options should work

(a) just build the right Island project for your platform(s), and change the Island reference in your test project to use that binary (either drag a project reference, or drag the .fx file into your project).

(b) if you do wanna use Island.Shared directly, check the actual Island project for your platform(s) and make sure you copy the exact settings, such as Default Uses Clause, etc that it has.

if that both fails, can you send me the project as you have it? I assume you haven’t made any actual changes to the Island code yet? (if you did, id say try and get the unchanged code to work first).

sry was not at home… I have to say, im not sure I understand correctly this part: Do you mean with “actual” IslandProject this one here?

since yea i would like to use t he shared directly

btw dont wonder why there is “Island.shared” muissing, i manually removed it BUT: it told me b4 that this .sln couldnt find "Island.shared "project


No idea; it’s not missing here, obviously. Did you open the Island.sln or the Island.Windows.elements project separately (which would create a new solution with just the one project). You’d have to add the Shared project to that new .sln manually.

and with "check for its settings you mean this one?


i had a conversation with carlo about this and he said that I did some deletion of files (but replaced them with another merge version of those which got deleted) which apparently broke how the compiler sees the Island types or smth along those lines and it caused the compiler to forget the types apparently… so I am wating for him to see how I can do this, if need be I will restore the files i merged b4 into another one, so the conflict can resolve.

Probably best to revert to a clean clone, get that to build, and then bring your changes back into the current code base?

hmm, you mean I should merge again with the current clean clone?

need to do since I dont wanna lose the commits.

No. back up your code. get a clean checkout from git. get that to build. then add your changes back manually, see if it still builds.

Marc I did itt kind of already what u mentioned, made a clean clone ISlandRtl, saved my changes ofc b4, then added and commited them into the newly cloned repo on my machine, it builds all other files fine (which is the important part!) and renamed the module, which was the reason for the entire trouble, to Numeric.pas, and let carlos version (integer.pas and floats.pas) as is, and all other files work now, except i have 400 other compiler errors in my file :smiley: but this I can solve my self now I think since it has to do with type conversions there the compiler may be confused. But thx for the suggestion, worked!

As I said, I fixed now my other compiller issues and all builds fine, thx alot man, this was a good hint, since I would have tried otherwise to merge my mess with the clean repo and yea bigger mess then haha

Ok the only thing now I would like to know to finally bring that thing an end, So I have a better view what is currently working when I could create a consoleApp embeded in “IslandRtl.Island.Shared” like this image:

sadly he says “Uknown Type”? How can i solve this last part.

Ok I fixed that too myself, I justdid it the other way around by creating an isolated ConsoleApp and then adding IslandShared to the .sln of the consoleapp and can now even debug the shared project!

Note that your project is not using your copy of Island RTL, it’s using the default one. Drag your Island (Windows) project down onto your console project to create a project ref.

But what is TNumeric? Something you wrote? Why are you adding it to Island RTL, and not in your Owen code? What’s the end goal here?