Looking support for {$I Jedi.inc}

Hi Team,

We are looking for the support related to Jedi.inc file.
How we can add one Jedi.inc file for application.
If I added file then I unable to set breakpoints.
Kindly find attached sample application.

JediIncTest.zip (36.0 KB)

Thanks you!

Hi Team,

We are waiting for support, Let us know if required any more details.

Thankyou!

My apologies for the delay. Officially, we do not support this, as this file was made for Delphi, not Oxygene, but I’ll have a look at what fails and what we can do to improve support for it…

thanx!

Hmm, the Jedi.inc file in your zip is empty?

That said, I;'m logging two unrelated issues, (a) that apparently $INC is not allowed before the namespace declaration and (b) that Jedi.inc is not found from subfolders, without an exploit “…”

Thanks, logged as bugs://85121

Hey Team,

More specific to our problem is,
Whenever we are adding {$I Jedi.inc} we are unable to set the debugger(using F9 or using mouse) in file which we included Jedi.inc.

Thankyou!

Ah ok. that’s in Visual Studio, I presume? I’ll log an issue for the VS team. That said, does the project you sent compile for you, as is? because it does not, for me…

Thanks, logged as bugs://85125

This works now if you specify a proper relative path (and properly errors otherwise). IE subdir\TestFile.pas should use …/Jedi.inc or …\Jedi.inc (both will work).

bugs://85121 got closed with status fixed.

Hello. I have just tried to open the file and set breakpoint. It worked fine. Please let me know if you still experience the breakpoint problems with the latest build.