NamedPipe as Windows Service requires client to have admin previledge

I have a ROSDK namedpipe server as Windows service but it will deny access for client application if client is not admin.

Is this expected? Or some settings I did wrong?

Thank yo


You can change this behavior with TRONamedPipeServer.AllowEveryone property.

1 Like

Thank you very much

How to set the windows service up so after installation using /install, it starts automatically without manually start it ?


you can use net start [servicename] for starting windows service