.NET framework with DevExpress 20

WebApplication2.rar (8.0 KB) Hi

I installed VS 2019 Enterprise, then RemObjects Elements, then DevExpress .NET V20.
I create a new project (Classic .NET web application)
But I cannot see the DevExpress .NET Controls, I tried to do installation in different PCs, but all are the same.

When I create a VS C# classic web application all are fine, and I can see the DevExpress controls and I can create my web application using DevExpress.

While using Oxygen…
I cannot see DevExpress in the toolbox.

  1. So I manually add reference to DevExpress
  2. I manually write the ASPX tags for DevExpress Web Dashboard Default.ASPX
  3. I created an event for the ASPxWebDashboard
  4. I put in uses DevExpress,= and DevExpress.DashboardWeb;

Try to compile, then I get following error

Severity Code Description Project File Line Suppression State
Error (E28) Unknown type “DevExpress.DashboardWeb.ASPxDashboard” WebApplication21 C:\Users\Kifah Najem\source\repos\WebApplication2\WebApplication2\Default.aspx.Designer.pas 22
Severity Code Description Project File Line Suppression State
Error (E26) Unknown namespace “DevExpress” in uses list WebApplication21 C:\Users\Kifah Najem\source\repos\WebApplication2\WebApplication2\Default.aspx.pas 9
Error (E26) Unknown namespace “DevExpress.DashboardWeb” in uses list WebApplication21 C:\Users\Kifah Najem\source\repos\WebApplication2\WebApplication2\Default.aspx.pas 10
Error (E28) Unknown type “DevExpress.DashboardWeb.DashboardLoadingWebEventArgs” WebApplication21 C:\Users\Kifah Najem\source\repos\WebApplication2\WebApplication2\Default.aspx.pas 15

So how we can make Element to run please

I notice that when I create new element project in VS, always it is set to 4.0, even when in settings showing 4.5.2 or 4.8

1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(2084,5): warning MSB3274: The primary reference “DevExpress.Charts.v20.1.Core, Version=, Culture=neutral, PublicKeyToken=b88d1754d700e49a, processorArchitecture=MSIL” could not be resolved because it was built against the “.NETFramework,Version=v4.5.2” framework. This is a higher version than the currently targeted framework “.NETFramework,Version=v4.0”.

This out put when I compiled my project, while in settings it is 4.5.2

Curious. It looks like DevExpress might be doing something thats specific to VC#. Can I ask to reach out to their support, as well? That said, I’ll make sure the VS team has a look at this next week.

This sounds like you might need to add more additional references.

Hmm. the project you sent shows


Can you set the build log verbosity to maximum (Tools|Options|Projects&Solutions) and send me a the full log output of a rebuild?

When I add following line to project file “.element”
it compiled, but when I try to brows I get following error
Compiler Error Message: CS1061: ‘default_aspx’ does not contain a definition for ‘ASPxWebDashboard1_DashboardLoading’ and no accessible extension method ‘ASPxWebDashboard1_DashboardLoading’ accepting a first argument of type ‘default_aspx’ could be found (are you missing a using directive or an assembly reference?)
knowing that the events are defined

using following project file, build has no error

<?xml version="1.0" encoding="utf-8"?> Debug AnyCPU 2.0 {C352B5C0-BDC4-4B06-A6EF-63DD0E75F69D} {349c5851-65df-11da-9384-00065b846f21};{fae04ec0-301f-11d3-bf4b-00c04f79efbc} Library Properties WebApplication22 WebApplication22 v4.7.2 true 44398 true full false bin\ DEBUG;TRACE prompt 4 true pdbonly true bin\ TRACE prompt 4 True ..\packages\Microsoft.Web.Infrastructure.\lib\net40\Microsoft.Web.Infrastructure.dll ..\packages\AspNet.ScriptManager.bootstrap.3.4.1\lib\net45\AspNet.ScriptManager.bootstrap.dll ..\packages\AspNet.ScriptManager.jQuery.3.4.1\lib\net45\AspNet.ScriptManager.jQuery.dll ..\packages\Microsoft.AspNet.ScriptManager.MSAjax.5.0.0\lib\net45\Microsoft.ScriptManager.MSAjax.dll ..\packages\Microsoft.AspNet.ScriptManager.WebForms.5.0.0\lib\net45\Microsoft.ScriptManager.WebForms.dll ..\packages\Microsoft.AspNet.Web.Optimization.1.1.3\lib\net40\System.Web.Optimization.dll ..\packages\Newtonsoft.Json.12.0.2\lib\net45\Newtonsoft.Json.dll True ..\packages\WebGrease.1.6.0\lib\WebGrease.dll True ..\packages\Antlr.\lib\Antlr3.Runtime.dll True ..\packages\Microsoft.AspNet.Web.Optimization.WebForms.1.1.3\lib\net45\Microsoft.AspNet.Web.Optimization.WebForms.dll ..\packages\Microsoft.AspNet.FriendlyUrls.Core.1.0.2\lib\net45\Microsoft.AspNet.FriendlyUrls.dll ..\packages\Microsoft.CodeDom.Providers.DotNetCompilerPlatform.2.0.1\lib\net45\Microsoft.CodeDom.Providers.DotNetCompilerPlatform.dll About.aspx ASPXCodeBehind About.aspx Contact.aspx ASPXCodeBehind Contact.aspx Default.aspx ASPXCodeBehind Default.aspx Global.asax Site.Master ASPXCodeBehind Site.Master Site.Mobile.Master ASPXCodeBehind Site.Mobile.Master ViewSwitcher.ascx ASPXCodeBehind ViewSwitcher.ascx Web.config Web.config 10.0 $(MSBuildExtensionsPath32)\Microsoft\VisualStudio\v$(VisualStudioVersion) True True 51087 / https://localhost:44398/ False False False This project references NuGet package(s) that are missing on this computer. Use NuGet Package Restore to download them. For more information, see http://go.microsoft.com/fwlink/?LinkID=322105. The missing file is {0}.

attachedlog.txt (128.1 KB) the log file

That would be the same as


TargetFrameworkVersion is a legacy setting, TargetFramework is the more modern.current version, as it also specifies the framework, type (eg .NETFramework vs .NETCore.)

When I use only
it dose not compile and give an error, while when I put both the above line as below line project compile, but still when I try to run, I get error as below

Compiler Error Message: CS1061: ‘default_aspx’ does not contain a definition for ‘ASPxWebDashboard1_DashboardLoading’ and no accessible extension method ‘ASPxWebDashboard1_DashboardLoading’ accepting a first argument of type ‘default_aspx’ could be found (are you missing a using directive or an assembly reference?)

Well, this is my new findings.
From ASPX page when I create a new event for dxDashboard, the event it is created above protected section, so when I compile and try to run\browse I get the error which is in previous post.

I simply moved the events definitions to below protected section, and compile and run correct as below

_Default = public partial class(System.Web.UI.Page)

method ASPxWebDashboard1_DataLoading(sender: System.Object; e: DevExpress.DashboardWeb.DataLoadingWebEventArgs);
method ASPxWebDashboard1_BeforeExportDocument(sender: System.Object; e: DevExpress.DashboardWeb.BeforeExportDocumentWebEventArgs);
method ASPxWebDashboard1_DashboardLoading(sender: System.Object; e: DevExpress.DashboardWeb.DashboardLoadingWebEventArgs);


Oh wait, this is going to be using the Legacy target, right? Could be you need TargetFrameworkVersion then, yes.

While I doin’t see this error, only the “unknown namespace DevExpress” ones (which are expected, since I dont have that dll), I would expect this could be a follow-up error from those.

I suggest top review the references an d make sure you reference all the required DevEx .dlls to resolve those errors first, and see if this last error then goes away as well…


Doing more test… :wink:
first once I use <TargetFrameworkVersion>v4.7.2</TargetFrameworkVersion>
then solution compile correctly.

But I am having strange behaviour, and every time I have to alter\update the project file outside VS manually to be able to open it again.

Example of my findings (Knowing that I am using the trial edition)
I created a folder called myClasses, then I copy 2 C# files and paste them to myClasses folder, then I add those 2 files… I close the project then open it again… project showing (Unloaded) and could not open it.
I try many times to loaded, I try to move the 2 fils to root project folder, but the same issue… Once I change the extension to .pas, then project loaded successfully regardless the 2 files inside a folder or not.

I Used the 2 files as described above (.PAS which exists inside a folder), inside those files I created a new public class with some methods… then I open default.pas, and I tried to use those classes, well during writing the code, I can see the classes in code completion, but once I try to compile, I get an error that the class is not known… so I move the 2 files to project root, then try to compile, and compilation success.

if I am not mistaken there is some compatibility issue with VS2019.
Please can you clarify those errors if there is a solution.

I am using Oxygen V8 in my company with bundled VS2013 since many years, and it is working great

hmm, do you get any more specific error message when you try to reload and it fails. What steps do you use to add the files? does the project file look broken after the files get added?

I assume you are using build .2551, yes?


There is no error message.
I simply use VS to Add existing item\Add new folder
Project file is not broken, but when I add the C# files, then save and close VS, then open it again and the project did not loaded, then I had to do some test, and when I update the project file and change file extension fro cs to pas, hte project loaded normally

I assume you are using build .2551, yes?

No Idea, I download the demo from the website

How does the not loading manifest — surely it must say something?

Can you find out? the version should be shown in the About dialog.


I can see the problem with Unloaded project. I am working on a solution but meanwhile when project is in Unloaded state you can invoke “Reload project” command in Solution explorer context menu, and that will load the project.

Thanks, logged as bugs://84946

I thought I suggested that, and choosing Reload also failed?

bugs://84946 got closed with status fixed.


I believe we have this issue fixed; I have uploaded a new build for you to your Personal Downloads folder: https://www.remobjects.com/portal/downloads/personal.


1 Like

Thank you, I will try it and send you feedback

Should I make a new installation or an upgrade.
What issues shall I check

1 Like