Nexus DataAbstract Driver Memo Fields Issue -at least with 10.3.1 if not b4

delphi
nexusdb

(rposeikacbautomation) #1

I have a DA DB server connected to a Nexus DB server that has been
in use for years.
-A particular DA server app has not been updated for a while.
-I just added some new tables to the DA server app to reflect changes in the nexus DB server.
-THERE IS A SIDE-EFFECT… On tables with memo string fields (No changes made and were working previously) - the memo field can be read, but if a new record is made or a modification is made to the blob memo - the data is written as basically “???”.
–Reading existing data is ok, as soon as I POST (apply udpate to server) the corruption occurs.
Is there a change somewhere I need to consider?
-This may be an issue before 10.3.1. I cannot say.
The previous DA Server (compiled sept 2018 works just fine).

TIA


(rposeikacbautomation) #2

Seems to be an issue with 10.2 also with latest DA…
rgds


(EvgenyK) #3

Hi,

can you create a simple testcase that reproduces this issue, pls?
you can drop it directly to support@


(rposeikacbautomation) #4

Evgeny
ok -I have a very simple test project.
I have Nexus 4.5009

I will send you one (1) TestMemo.nx1 file and the project I used for
Delphi 10.3.1 with RemObjects Data Abstract for Delphi, Server Edition - 9.5.111.1399

The delphi project was created with the DA wizard for
VCL server and client.

the nexus alias is called
AdrMsgr
and the file is located in c:\temp

The DAServer connects to localhost.

The DAClient has both the DA client AND a nexus direct connection.
The DA environment has the issue descrived. The Nexus environment ‘works’. If I write text via the DA connection - it posts ??. If I write text via the nexus connection - the text posts and is read after a refresh via the DA connection.

When you mean ‘drop’ at support@ you mean email?
thanks again


(EvgenyK) #5

yep, email with testcase


(rposeikacbautomation) #6

Please check email for support@ - just sent
tks


(rposeikacbautomation) #7

email was REJECTED:
Unfortunately some attachments in your email message to [“support@remobjects.com”] (titled Fwd: [RemObjects Talk] [Data Abstract] Nexus DataAbstract Driver Memo Fields Issue -at least with 10.3.1 if not b4) were rejected.

Details:
TestMemo.nx1: Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, zip, 7zip, rar, bmp, txt, pas, cs, doc, docx, 7z, mp4, gz, tar, xlsx, pdf, dll, lic, license, rodl, tgz, oxygene, elements, hydrogene, cab, eml, odt, json, xml, xsd, xslt, android-xml, h, hpp, cpp, c, inc).

If you believe this is an error, contact a staff member.


(EvgenyK) #8

never mind, I’ve receives files.
for avoiding such errors, pls put .nx1 into .zip too


(rposeikacbautomation) #9

roger dat
:grinning:


(RemObjects) #10

Thanks, logged as bugs://82024


(rposeikacbautomation) #11

thank you!


(RemObjects) #12

bugs://82024 got closed with status fixed.