No longer able to debug after setting a breakpoint


(JohnMoshakis) #1

Hi,

I set a breakpoint in a referenced assembly of a dotnet core console application. When I stopped the application and tried to debug again I get

~> The process failed to start with the following error: System.Exception: System.FormatException: Input string was not in a correct format.
~> at System.Number.StringToNumber (System.String str, System.Globalization.NumberStyles options, System.Number+NumberBuffer& number, System.Globalization.NumberFormatInfo info, System.Boolean parseDecimal) [0x0005e] in :0
~> at System.Number.ParseInt32 (System.String s, System.Globalization.NumberStyles style, System.Globalization.NumberFormatInfo info) [0x00014] in :0
~> at System.Int32.Parse (System.String s) [0x00007] in :0
~> at DebugHost.Program.Main (System.String[] args) [0x0096d] in <0a5bc25ea06544fe826bd88741a209a8>:0
~> at RemObjects.Oxygene.MI.DebugEngine.ExecuteCommand (System.String s) [0x000ff] in <147c0dc9d8f040b69a4341015e5bf0cc>:0
~> at RemObjects.Oxygene.MI.DebugEngine.CreateBreakpoint (System.String aFn, System.Int32 aLine) [0x00031] in <147c0dc9d8f040b69a4341015e5bf0cc>:0
~> at RemObjects.Oxygene.CoreDebugEngine.MIDebugEngine.Start () [0x006c4] in <48ebbf2e83fe4b18ab865fa2d5a66a1a>:0
~> at (wrapper native-to-managed) RemObjects.Oxygene.CoreDebugEngine.DebugEngine:Start (RemObjects.Oxygene.CoreDebugEngine.DebugEngine,System.Exception&)

Setting a breakpoint anywhere now no longer works. I can run with the debugger but thats it. Restarting Fire or clearing all breakpoints doesnt seem to fix it.

Cheers,
John


(RemObjects) #2

Thanks, logged as bugs://82017


(Carlo Kok) #3

Can you tell me the exact (full) filename for the file you’re setting a bp in?


(JohnMoshakis) #4

The original file I set a breakpoint in was

/Users/JohnMoshakis/Documents/develop/Dapper/Dapper/SqlMapper.Async.cs

And Im trying to set breakpoints in

/Users/JohnMoshakis/Documents/develop/Echoes/Core/PostgresDataAsyncConsoleApplication/Program.pas

Do you know where it might saving state ? I no longer have any breakpoints set and its still giving me the same error when I try and set a breakpoint.


(Carlo Kok) #5

Should just be the .user file next to it. Can you send that to me?


(JohnMoshakis) #6

PostgresDataAsyncConsoleApplication.sln.fire.user.zip (1.4 KB)


(Carlo Kok) #7

Can you send the .cache file too ? (sorry; had the wrong file)


(JohnMoshakis) #8

PostgresDataAsyncConsoleApplication.sln.fire.cache.zip (6.5 KB)


(Carlo Kok) #9

delete that file and you should be able to get going again. I’ll look at the project of course.


(Carlo Kok) #10

can you try todays build? I think this is fixed.


(RemObjects) #11

bugs://82017 got closed with status fixed.


(JohnMoshakis) #12

Thanks. I think its fixed as well.


(JohnMoshakis) #13

It does seem to stop respecting the breakpoints I set. I tried setting a few more and after a while its not hitting any of them. Removing the cache file fixes it.

These are the temp files after its stop respecting my breakpoints

Archive.zip (5.7 KB)

It feels like its related to me setting “automatically find symbols within this folder hierarchy, in the future”