NPGSQL link to SQL error


i recently updated RO/DA to version (using Npgsql Version 4.1.1). Since then linq queries using a where clause produce an invalid SQL.


var q = from r in linqLocalDataAdapter.GetTable<Mitarbeiter>()
             where r.MA_Loginname == username.ToLower() && r.MA_Austritt == null
             select r;

Produces the following SQL / Parameters:

SELECT "t0"."ma_loginname", ...
FROM "mitarbeiter" "t0" WHERE (("t0"."ma_loginname" = :) AND "t0"."ma_austritt" IS NULL) 

p0 => test

As you can see, the parameter name p0 is missing in the sql.

With the previous installed RO/DA Version this worked without errors an generated the correct SQL string containing the parameter name p0.

Thanks, logged as bugs://83380


I would assume that you have modified your DataAbstract.daConfig file to be able to use Npgsql 4.1.1 . Could you upload it here or to support@?


no, i didn’t modify the daConfig file. I only installed Npgsql via the nuget package. I know that the Schema Modeler could not connect to the database with this version but this was no problem at runtime.
For testing purposes i also tried it with Npgsql version 4.0.9, that didn’t work also.

Btw. the in RO/DA bundled Npgsql.dll has version 4.0.10 but the bundles daConfig file references version 4.0.9.


Unfortunately I was not able to reproduce this. For me parameter processing works as expected.

Could you create a testcase and send it to support@ ?


Hello Anton,

i could also not reproduce the error while creating a new RO/DA project and using NPGSQL. Therefore i migrated my existing code and classes to this newly created project and it works at excepted.

Maybe the problem only occurs when updating from such an “old” RO/DA Version ( to the current version ( But i have not time to further test this scenario.

Best regards, Daniel

bugs://83380 got closed with status cannotrepro.