Nuget Package Manager

visual-studio

(landrydog) #1

Can’t seem to access Nuget Package Manager in VS 2015 that comes with Elements.

It doesn’t show up in Tools Menu nor by right-clicking solution.

Please advise.

Thanks


#2

I’m not in front on my Windows machine right now, but did you try installing it from the VS Marketplace?


(landrydog) #3

Hi Conio,

Yes, I tried that without success. See attached screen shot.

Ben


#4

Seems I was mistaken. I thought it was possible with VS 2015 Update 3 installed but I was wrong.


(landrydog) #5

Yes. Did that too.

Nuget pkg mgr also doesnt show up in the online gallery of extensions to install.

I also tried clean reinstall of vs 2015 and oxygene from rem downloads. No luck.

Thanks

Get Outlook for Android


#6

Maybe you can change the manifest or build NuGet yourself then…

I’m guessing trying to edit the VSIX will break it’s signature or something. Seems like the required change is adding a line like:

<InstallationTarget Id="Microsoft.VisualStudio.IntegratedShell" Version="[14.0,15.0)" />

in:


(landrydog) #7

I will try test on new/clean win 10 pro 64bit system.

Assume that this is not a known issue?

Only me?

Get Outlook for Android


(landrydog) #8

Hi

I downloaded and tried to install Elements with VS 2015 on brand new/clean Win10 Pro system.

See attached error.

I suppose I have to install and use either VS 2013 Free version or VS 2015 community with Elements?

Is there any downside to either?

Please advise.

Thanks


(marc hoffman) #9

Go for 2015 or 2017 Community. In fact, 2015 Community is a superset of the Shell we install,


(Jolyon Direnko-Smith) #10

Yes, I was about to say… VS Community is effectively simply VS Professional with a different license. Use is free for individuals, even for commercial app development. Even in enterprises/organizations, free use is permitted with certain limitations and caveats.

See “Usage” section here: https://www.visualstudio.com/vs/community


#11

Don’t know about you guys, but I installed the version with the VS Shell on Windows 10 and it worked for me.
I used the 10.0.0.2255 installer on Windows 10 1709 x64 (build 16299.192).

The Community edition trick is fine, as long as you don’t have a problem with the licensing restrictions…


(marc hoffman) #12

Yeah, in most cases it is.


(landrydog) #13

Hi,

When you say it worked fine, do you also mean that you were able to install Nuget Package Manager from Tools/Extensions and Updates Online Gallery?

Ben Cohen

Director of IT

Los Alamitos Race Course

714.820.2646


(marc hoffman) #14

i think he meant that VS2015 installed fine for him.


#15

This.

I opened a bug on the NuGet issue tracker.

In the meanwhile I can add that if the license restrictions of the Community edition prevent you from using it you may try to find the Visual Studio 2013 Shell. Elements will install on it and the NuGet extension for VS 2013 will work on the integrated shell.


#16

(landrydog) #17

Ok.

Out until next week.

I ll try 2015 or 2017 1st to see results then.

Thank you

Get Outlook for Android


#18

So, Microsoft and the NuGet maintainers suck. They didn’t even bother to respond to the issue.

If you still want to install the NuGet extensions on VS 2015 Shell you can do that in two ways:

  1. Build the NuGet extension on your own.
  2. Patch the official extension.

The easier way is to patch the official extension. Download the VSIX from the VS Marketplace, extract the VSIX, and edit the extension.vsixmanifest file to add the middle line from the following:

  <InstallationTarget Id="Microsoft.VisualStudio.VSWinDesktopExpress" Version="[14.0,15.0)" />
  <InstallationTarget Id="Microsoft.VisualStudio.IntegratedShell" Version="[14.0,15.0)" />
</Installation>

Pack it again in a ZIP with a VSIX extension and install it.

You’ll get a message saying the digital signature is invalid, but that’s find since you were the one messing with the VSIX contents.

image

To build your it on your own you’d do something like:

git clone https://github.com/NuGet/NuGet.Client.git
git checkout 3.4.4-rtm

Open NuGet.Clients.sln and build the VsExtension project. I used Visual Studio 2015 Community to do it. I had to uninstall the built-in NuGet extension for the final parts of the build to work, and the VS Shell thought there’s an update available (because the reason I built was 3.4.4.0 and the markplace has 3.4.4.1321). No real reason to do that.