Oxygene/.NET importing COM issue

I created an Oxygene/.NET WinForm application. Then I try to import an COM Type Library by References->Add Reference

The COM Lib was added to the References list.

Then when I tried to build it, I got the following error:

C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\RemObjects Software\Elements\RemObjects.Elements.Echoes.targets(70,3): error : Cannot resolve COM References, as TlbImp.exe was not found
Done building project “WindowsApplication1.elements” – FAILED.

Any heads up?

It looks like you don’t have the Windows SDK installed, which is what provides tlbimp.exe and is required to import COM references. Can you check?

We read the Windows SDK folder from HKLM/SOFTWARE\Microsoft\Microsoft SDKs\Windows\CurrentInstallFolder in the registry, and search for the tlbimp.exe in any of its subfolders, if present.

Thank you. The SDK is indeed installed.
It turns out - the Dll I tried to import is not a COM dll.

I guess the error emitted could be more accurate.

I double-checked; the error is accurate, the only way this message would sow is if the .exe actually was not found. (of course that fails before it would look at the actual .dll and determine if it’s valid.

So, does HKLM/SOFTWARE\Microsoft\Microsoft SDKs\Windows\CurrentInstallFolder point to a folder that exists, and does a file called tlbimp.exe exist in any of its subfolders?

I am using VS 2017 on Windows Server 2016. The following is the only registry I found that has “Microsoft SKDs”.

It totally works fine without any error if I build Oxygene/.NET with a valid COM reference; the error only throws out when the added Dll is not a COM Lib.

Here is a list of tlbimp.exe I could found on my computer:

So, is there a CurrentInstallFolder item under the Windows key?

No I did NOT see a folder with that name CurrentInstallFolder.

But strangely, there is no problem to build if the COM reference is a valid one.

CurrentInstallFolder would be a VALUE in the “Windows” Key

Nope. I didn’t see “Windows” key has any values

Curious. ok, that at least explains why I don’t find it ;). I’ll need to do more research to see if that’s a “normal” condition…