Oxygene projects not loading in Visual Studio 2015

Had to resurrect and old application developed with Visual Studio 2015 and Elements
Reverted repo back to the old release branch.
Installed Visual Studio 2015 Community with Updates.
Installed RemObjects Elements
Opened the solution in Visual Studio.
Solution main project is a C# project…loads fine.
All Oxygene projects fail to load.
Error message is “The type initializer for ‘B.d’ threw an exception.”

Tried to load the Lambdas sample solution…same error.
Tried to load the Loops sample solution…same error.
Tried to load the Interfaces sample solution…same error.

No Oxygene projects will load.

This used to work with VS 2015 and the same Elements version.
Cannot find any info on the error message.

Any help on what the problem is would be greatly appreciated.

I’m afraid we do not really support Visual Studio 2015 and Elements 9 anymore. Can you update to the latest Elements and a newer VS or Water, and see if this issue is solved then?


Unfortunately, cannot update to new versions. The intent here is to build the app the exact same way it was built back in 2016.

I probably could wipe my computer clean of all newer Visual Studio installs, all .NET installs, and reinstall VS 2015 and Elements and… it may work. But that is a huge pain because, when done with this project, I would have to uninstall all this and then reinstall all the new stuff again. Or, create a dual boot / VM setup with the dev env for old and new…either way…too much work.

Fortunately, I found an old dev computer from back in 2016/2017 and it has VS 2015 and Elements installed. I booted it up and cloned the repo and checked out the appropriate branch…all worked!

Still pissed because never figured out what the problem was. But got the projects loaded and built, so all is good.