Problem with Elements/DA for updating table definitions

Using Elements
Using Data Abstract

I’m trying to use the context menu to update my table definitions in my DA class lib. This has always worked, but now the DA dialog comes up with teh spinning blue circle that never goes away. This seems new in this version of Elements I’m afraid. Is this a known issue?

if I choose Update Table Definitions by right clicking on a .relativityClient file, the above happens.

if i choose Update Table Definitions by right clickin on the *TableDefinitions.pas file i get the following error in the output window:

Table Definition classes generator failed:
System.NullReferenceException: Object reference not set to an instance of an object.
   at RemObjects.DataAbstract.IDE.VisualStudio.IDEIntegrationService.GetProjectItems(ProjectItems source, Func`3 filterByNameAndItemType, IList`1 destination)
   at RemObjects.DataAbstract.IDE.VisualStudio.IDEIntegrationService.GetProjectItems(Boolean filterByCurrentProject, Func`3 filterByNameAndItemType)
   at RemObjects.DataAbstract.IDE.VisualStudio.IDEIntegrationService.FindProjectItem(Boolean filterByCurrentProject, String filename)
   at q.d(IProjectItem a)
   at q.g(IProjectItem a)
   at R.a(Boolean a)
   at RemObjects.DataAbstract.Designtime.Wizard.TableDefinitionsGeneratorWizard.ExecuteWizard(Boolean startedFromContextMenu)

FYI…I reverted back to 2595 and Update Table Definitions worked as before.


Yes, it is new. We are currently investigating the issue.

Am I right that you use Oxygene in your ClassLib project?

Yes sir.


We have found the issue and fixed it. Latest Data Abstract releases (.1503) will contain a fix for this issue. Also a minor issue in Elements was fixed that actually caused this NRE

Sorry for the inconvenience

(both will be out today, on Preview)

Thanks guys!

1 Like