Publish of ASMX service goes in a loop

Open visual studio and create a new project - RemObjects Mercury, ASP.Net Classic Web Service Application.

Right click the project in the solution explorer and press Publish.

Set the target location to bin\Release\Publish and the configuration to Precompile.

Now press the Publish button, and the asmx site is compiled and the published, but during publish, the following line keeps being repeated in the output:

and the publish never finishes.

After about 5 minutes, it goes to repeating:

Logged as bugs://E25653.

Hello Theo.
Could you please give a project that shows the problem? I tried with a newly create webservice and I can’t reproduce the endless loop.
It more looks like we have some problems with resolving refs here but not with publish itself.

Just tried.

It only happens when you do a solution rebuild and then publish.

But I see that it is publishing now, the loops stops now after about 30 secs.

Close the issue for now.

With the latest version from the firehose it takes some time for the resolving, but it finishes within 30 secs now.

Longer than it should IYO?

bugs://E25653 was closed as unable to reproduce.