Schemas modeler won't run anymore

I’ve just updated from to the latest stable server edition and Schemas Modeler won’t run anymore: no error message, no splash screen: it quickly appears then disappears in the task manager.
I’m using Windows 11 Pro 22H2 22621.2428 with all updates.
I can’t see any logs in Userdata folder.


Try to launch C:\Program Files (x86)\RemObjects Software\Everwood\Bin\RemObjects.Everwood.LicenseManager.exe and update your license.

after this try to relaunch Schema Modeler again.

will Schema Modeler be closed silently?

It still doesn’t work. Also I tried running ServiceBuilder which asked for license download first and now runs correctly. Only Schema Modeler is problematic. Any other ideas ?


  • rename/move C:\Program Files (x86)\RemObjects Software\Data Abstract (Common)\Bin\RemObjects.DataAbstract.Unmanaged.dll

  • launch Schema Modeler
    will it be silently closed?

  • Close Schema Modeler

  • restore RemObjects.DataAbstract.Unmanaged.dll

  • if main form after step 2 was shown do additional steps:

  • add to RemObjects.DataAbstract.Unmanaged.ini:

Debug = 1
  • check %appdata%\RemObjects Software\Schema Modeler\RemObjects.DataAbstract.Unmanaged.log.
    it may contain some additional info about this issue

Renaming RemObjects.DataAbstract.Unmanaged.dll doesn’t change anything.
Nor does adding the debug line to the ini file: nothing is shown and app never appears on screen.
Also, the %appdata%\RemObjects Software\Schema Modeler\ only contains folders names “Licenses” and “Relativity”.
What’s next ?


investigating …


copy C:\Program Files (x86)\RemObjects Software\Everwood\Bin\Echoes.dll to C:\Program Files (x86)\RemObjects Software\Data Abstract (Common)\Bin folder and override existing file.

it should solve this issue.


It works. Thanks.

1 Like