SOAP Webservice Namespace issue

delphi

(rganz) #1

I have to consume a SOAP Webservice from SAP PO, when I use the provided WSDL with SOAP-UI I get the result as expected (left side of the comparison image). With Remoting SDK it does not work, I get an undefined server error… I’m not sure what exactly the issue is, but I suspect that “V1” on every parameter and the “V1” namespace declaration on “Z_WSPOS_MAT_AVAILABILITY_EXT” level instead of envelope level could be the problem.

From an earlier post here I know about these attributes like “InputChildrenNamespaces -> *”. I tried to add it to the parameters but the generated xml didn’t changed. Is there another attribute I can add?


(EvgenyK) #2

can you create a simple testcase that reproduces this case, pls?

do you have InputChildrenNamespace=* in Z_WSPOS_MAT_AVAILABILITY_EXT attributes?
after adding this attribute you should rebuild _Intf, _Invk too


(rganz) #3

Testcase sent to support@… Yes that’s what I tried, adding InputChildrenNamespace=* to all in-parameters of Z_WSPOS_MAT_AVAILABILITY_EXT.