Soapmessage integer datatype


i am trying to create a soap web service on .net. i did the necessary development. and the result of the wsdl of my web service is following. When i am using this web service, i am getting the following error. How can i solve this issue?

Note; if i create soap web service with delphi, integer type is appearing “xs:int” instead of “tns:Integer”…

And also, it is adding “Service” word end of the service name(you may see the example block at the end of this message). it should be “SManagement” because, client should connect delphi and .net web services created on RemObject. How can i change it to “SManagement” ?

No global type was found: {}Integer

   <xs:element name="Service1___DoSomething">
          <xs:element name="someValue" type="xs:string">
          <xs:element name="intParam" type=**"tns:Integer"**>
<wsdl:service name="**SManagementService**">
<wsdl:port name="SManagementPort" binding="tns:SManagementBinding">
<soap:address location=""/>


can you create a simple testcase that reproduces this case, pls?
You can drop it to support@ for keeping privacy

thank you.

I am writing here because this may help other friends.

I have solved the first issue. Remobj service builder application is creating rodl file with “Integer” and integer data type is appearing as “tns:Integer” in my .net project’s wsdl . Then i have editted the rodl file with text editor and changed “Integer” to “integer” and then wsdl created as “xs:int” in my project. This stuation is same with Int64 data type. i think this is a bug with SDK or ServiceBuilder application.

Still i could not solve the second problem. My problem is related with the part “<wsdl:service name=“SManagementService”>” of wsdl file. i created a service with service builder named as “SManagement”. but this name appeared as “SManagementService” in the wsdl file when i used this service in .net project. I am adding sample rodl file and the wsdl.

sample rodl file
CentroVIS.RODL (2.8 KB)

create wsdl on Service builder application and compare it with the following wsdl
<wsdl:service name=… line is different…

wsdl i got it from google chrome after debugging the .net project;
cvs.wsdl.txt (5.3 KB)

Remoting SDK for .NET :


You are using outdated version of Remoting SDK.
Can you retest this issue with the latest version of Remoting SDK, pls?
this bug may be already fixed.

Thank you. but i can download only “” version with my account. not newer. what can i do?


You can test with trial version of Remoting SDK ( Free 30-Day Trial | RemObjects Software )
I can recommend to use virtual machine for testing

thanks for advice. I have prepared a virtual machine and I tried the latest version of RemObj sdk. But the above 2 issue is still there.

problem 1 : Integer datatype is listed as “tns:Integer” instead of “xs:int”
problem 2 : sdk is adding “Service” word to my service name in wsdl.

i need a solution for second issue.


You can update RodlToWsdl.cs file and remove Service at this line:

this.WriteLn("<wsdl:service name=\"" + Unprefix(service.Name) + "Service\">", 2);

so result line should be

this.WriteLn("<wsdl:service name=\"" + Unprefix(service.Name) + "\">", 2);

after this you should recompile Remoting SDK for .NET

Logged as bugs://D19282.

Thank you so much for the advice.

I have created a snk file with the following sn.exe scripts. And then I have tried to rebuild using “…\Source\RemObjects.SDK.sln” solution, but not done perfectly. After rebuilding the all dlls under this solution, i can not edit httpserver’s dispatcher property. Kindly show me the successful build steps.

sn -k RemObjectsSoftware.snk
sn -i RemObjectsSoftware.snk RemObjectsSoftware


Looks like, IDE assemblies can’t use Remoting SDK assemblies that were recompiled manually because .snk is differ.

can you try this workaround:

  • backup recompiled Remoting SDK assemblies
  • reinstall Remoting SDK so VS will use original assemblies
  • use manually recompiled dll with your project(s) only

Yes, that is the way to go; do not replace the .dlls in ./Bin with the custom-built ones.

thank you so much. i have solved the issues by rebuilding sdk dlls. i have added reference the rebuilded dlls manually.

Now there is one more issue with the service response. Response is diffrent from delphi response for the same RODL file used. the rodl file can be found in my previous message. And i have attached the responses and the comparison.

So client is getting this error : SOAP-ENC:arrayType must end with a ‘]’ character.
Parameter name: value

xml delphi.txt (1.1 KB)
xml net.txt (1.1 KB)


Is it generated with RON v9.7.115.1441 or with the latest one (10.x) ?
Can you confirm that v10 generates the same wsdl, pls?


i am using v9.7.115.1441 version. i could not get response from newer version because the above issues. (dataType and service name issues in wsdl)


What client raises this error? What platform (Delphi, .NET, etc) is used for this client? what response it can’t parse?

Clients are normal .net application they are not using remObjects. in production, these clients are requesting from our server service written in delphi (with rem object) and there is no problem here.

We want to write same server service in .net with “Remoting SDK for .NET :”.

Our delphi server service response and the .net server service comparison is here. I hope the stuation is clear now.

Logged as bugs://D19285.


Can you create a simple testcase (RON server + non-RO client) that reproduces this issue, pls?
it will allow to fix this issue faster.
you can drop email to support@ for keeping privacy.


i have created a sample server and client project. (1.4 MB)