Some small Wishes for Water(perhaps also Fire?)

Heyo,

As mentioned in the tilte, I would really die for the feature to have the option to Zoom in and out, (my eyes would welcome you :D) and change the font, I love the old-pascalish-codefont (Couriew New :smiley: for instance) other than that, its a fine and compact IDE , good job!

Btw, its not that the font is ugly or so, I m only a fanactic of general more oldish fonts which embrace the old developer theme haha

You can change the font size in Preferences. There’s no official option to change the font, but you can do so in the registry under HKCU\Software\RemObjects\Elements\Water buy adding a string key called “CodeEditorFont”. Use at your own risk, as if the font isn’t properly mono-spaced, things wont be pretty.

Ok nice, i got the “Options” how come I didnt saw that button…

But it would be pretty awesome to have that as an option to water, to change the Font, it would complete the IDE i think :slight_smile:

But for now the workaround is fine

Im getting this error, when writing a reg-key:
“CodeEditorFont = CourierNew” OR “CodeEditorFont = Courier New”

Told you this was unsupported/experimental, and now you know why., but chances are yo didn’t get the font name exactly right…

Marc, I think there might be an issue with handling fonts that have spaces in their names. I’m getting the same crash as OP with Water (whatever’s current with .2605) when trying to use any of “Cascadia Code PL” “Cascadia Code” “Cascadia Code PL Regular” (each with and without quotes). Can you maybe give some guidance on how it expects to see font names with spaces in them, and whether we need to provide weight designations (Regular, Condensed, etc)?

John,

hmm. i just rad the name for the registry and ask the OS for the font my that name via new System.Windows.Media.FontFamily(aFontName);— I don’t see anything I my code that processes the name at all beyond that, and would thus explain the crash.

Do you have CodeEditorUseBold set in the registry as well? If so, can you try removing that, I can see a path where that setting and a custom font might fail.

Nevermind, that wont help. but fixed for vNext. Ny apologies (it had n sting to do with spaces, any custom font setting would cause this, because the bold/italic font names did not get set.

Much appreciated as always, Marc! Thanks! Will keep an eye out for it.

1 Like

Friday’s build will have the fix, but if you like, I can send you an interim build…

Sure, I’d be happy to validate!

Cool. a new build is running ing now; I’ll out it up in your Personal Downloads when its done, one hour or so.

Done.