SQLite.interop Nuget package installation failure

I’m facing an issue while install SQLite.intreop library. I have installed system.Data.SQLite package from Nuget package manager console but SQLite.intreop dll is missing in this package . when tried to install stand-alone SQLite.intreop dll Nuget package manager console gives an error here is the screen shot

And when I tried to build with above libary it shows the following error.

“Reference ‘SQLite.Interop’ could not be resolved for target ‘Echoes’ (Echoes .NET anycpu)”

Any chance i could get a small testcase project that shows this issue?

Uploading: WPFApplication1.zip…

Here is the sample code .In this I installed System.Data.SQLite package but when I tried to create table in database it gave “System.Data.SQLite dll not found” although System.Data.SQLite present in references

It looks like your attachment didn’t fully upload. Do you have Copy Local set on the SQLite package reference?

SQLite package was installed from Nuget package manager console .

Yes, but:

here is the LINK of sample code

Ok, then i don’t know, off-hand. Can I see a test case that shows this problem?

Sample Code

I n otice this project still uses legacy MSBuild-style packages; this should have been auto-migrated ‚— what version of Elements and VS are you using?

If I migrate it, it builds clean for me and deploys the following files:

                 EntityFramework.Core.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/EntityFramework.Core.dll)
                 EntityFramework.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/EntityFramework.dll)
                 EntityFramework.Relational.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/EntityFramework.Relational.dll)
                 EntityFramework.SqlServer.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/EntityFramework.SqlServer.dll)
                 Microsoft.Framework.Caching.Abstractions.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Caching.Abstractions.dll)
                 Microsoft.Framework.Caching.Memory.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Caching.Memory.dll)
                 Microsoft.Framework.Configuration.Abstractions.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Configuration.Abstractions.dll)
                 Microsoft.Framework.Configuration.Binder.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Configuration.Binder.dll)
                 Microsoft.Framework.Configuration.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Configuration.dll)
                 Microsoft.Framework.DependencyInjection.Abstractions.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.DependencyInjection.Abstractions.dll)
                 Microsoft.Framework.DependencyInjection.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.DependencyInjection.dll)
                 Microsoft.Framework.Logging.Abstractions.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Logging.Abstractions.dll)
                 Microsoft.Framework.Logging.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Logging.dll)
                 Microsoft.Framework.OptionsModel.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.OptionsModel.dll)
                 Microsoft.Framework.Primitives.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Microsoft.Framework.Primitives.dll)
                 Remotion.Linq.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/Remotion.Linq.dll)
                 System.Data.SQLite.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/System.Data.SQLite.dll)
                 System.Data.SQLite.EF6.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/System.Data.SQLite.EF6.dll)
                 System.Data.SQLite.Linq.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/System.Data.SQLite.Linq.dll)
                 System.Interactive.Async.dll (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/WPFApplication1.exe)
                 WPFApplication1.exe.config (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/WPFApplication1.exe.config)
                 WPFApplication1.exe.mdb (/Users/mh/Downloads/WPFApplication1/WPFApplication1/Bin/Debug/WPFApplication1.exe.mdb)

I get no error for missing “SQLite.Interop”.

I’m re-attaching the updated project:

WPFApplication1 1.bugreport.zip (71.4 KB)

I am using Visual studio 2019. Interop dll error was not in this sample code,it was in my realTime project.
when I tried to run spicific code block in another sample project it gave this error “Exception thrown: ‘System.DllNotFoundException’ in System.Data.SQLite.dll” in InitializeDatabase method of CreateDatabase class.The Error message was consoled in the catch block you can check that,athough the SQLite pacakge installed in this project

It seems we ar confusing a set of different and probably unrelated errors here.

But how am I supposed to investigate why you get

“Reference ‘SQLite.Interop’ could not be resolved for target ‘Echoes’ (Echoes .NET anycpu)”

when you send me a test case that doesn’t actually use/need it? :woman_shrugging:t3:

Let me clear you all the points

1-First I faced the following Error while converting my existing wpf application code to remObject template for which I Asked you the question
“Reference ‘SQLite.Interop’ could not be resolved for target ‘Echoes’ (Echoes .NET anycpu)"

2- Then I created a new TestCase project from scratch and installed System.Data.SQLite package,to verify weither or not I missed something while converting my WPF application, but this time the error has changed from ““Reference ‘SQLite.Interop’ could not be resolved for target” to “Exception thrown: ‘System.DllNotFoundException’ in System.Data.SQLite.dll”

3- In my next attempt I created another project but this time without the RemObject elements and istalled “System.Data.SQLite package” and surprisingly it is working fine,
so might be i’m missing something while working with RemObject or it has may be a issue with certain libraries like SQLite.
Hope this time I have cleared my points.

I take it your posted test case is supposed to reproduce this second error, then? I’ll check that in a bit (I didn’t try running it, as I was on macOS when looking at this, where I cannot run WPF, and because I was looking for a compile-time error).

When I run the app (my version with the fixed references, as posted above), I get an empty window; nothing happens, but also no exceptions, as far as I can tell. Can you confirm that the your error reproduces with my fixed version of the project (which uses proper NuGet package references)?

Test case that produced error

Yes, but does the error reproduce with my updated test case that fixed the proper NuGet references?

Your Test Case didn’t run on my machine because it hasn’t any solution file or project file that can run on visual studio

What are you talking about? It’s the exact same project as yours, just with the contents of the .elements file adjusted to use proper references.

yes I found solution file, actually when I extract It, there was not any solution file or project in it ,After open “WEBApplication1.elements” in water. It creates solution file automatically. But your test case didn’t run it gives this error “() Exception processing package reference EntityFramework : ZipEntry::ReadHeader(): Bad signature (0x00905A4D) at position 0x00000000” on build