"Stop on Breakpoints" always enabled at launch

A minor bug, but I’ve noticed that “Stop at Breakpoints” is always marked enabled at startup. If it should be disabled, then clicking it does nothing (still enabled) and then clicking it again sets it as disabled.

It seems to be only a UI bug, but I’m not sure. I have a lot of difficulty getting the debugger to run without freezing up (probably 10-20% success). It seems to help to run Debug with breakpoints disabled and then enable breakpoints during the debug session before triggering the code that has the breakpoint. All that to say, I can’t tell if it’s not running because breakpoints are (wrongly) enabled or because of whatever normally causes it to freeze.

You mean turn the option off, close Water, relaunch it, and it shows checked (on) in the menu, but when you run an app, it actually is off as expected?

I’d love to get some more details on that, to help fix that. Such as, what platform(s) and project types; what’s the exact behavior (Water just freezes up, never to recover? If so, could you by any chance attach a second copy of Water, or VS, as debugger, and get me the stack frames where it’s stuck?

Side note: whether breakpoints are enabled or not is stored as art of the solutions settings, not a global config. In case that matters/informs your expectations differently.

The menu and its hookup to the underlying setting setting looks pretty trivial, not much that could go wring here as far as I can see on a first review (didn’t test yet to see if I can repro, will do that when I’m on Windows, later).

Yes

Not sure about this piece. I can’t get my debugger to connect at all at the moment :confused:

Any chance I could TV in and have a look?

1 Like

I’ll send a Slack message

1 Like

Thanks, logged as bugs://85159 —Android debugger hangs

1 Like

Thanks, logged as bugs://85160 — for the BP menu showing having the wrong value