Tabs, Spaces Autoformating

Is there anyway for the editor to insert spaces rather than tabs?
Perhaps, even better is to allow me to turn off auto-formatting in Water so what I copy into it is what I get?

I’ve code in several editors I copy/paste between Water & them. To avoid ragged looking code all my other editors are set to put spaces instead of tab characters.


Water should preserve whether a file contains tabs or spaces, but it will always enforce it consistently. — i.e. if a file has inconsistent formatting to start with — some lines of a file have tabs, and others have spaces — it will unify on save to the default (spaces for Oxygene, tabs for everything else).

Thanks. Does it do any reformating? If my indents & spacing is set in Notepad++ (my preferred editor) do they remain in Water/Oxygene? When I past from Notepad++ Oxygene seems to reformat rather than accept it as posted.

That’s a separate thing but you can turn off reformat-on-paste in the editor page of the preferences dialog.