Unable to build Sugar for iOS or OSX

Trying to build Sugar (for the first time) having cloned from github today. Echoes and Cooper are fine. WinRT and WP8 are both unavailable (presumably because I am in a Windows 7 VM and haven’t installed any Win8 SDKs). My problem is that I cannot build the iOS or OS X projects (Legacy or Sugar).

With these projects I get an initial error ‘Could not load library “libxml2.fx”’. A ton of errors then ensue which all seem to be a consequence of this initial error.

Help ? :S

you will probably need the very latest beta/gamma drop of Oxygene, as Sugar is on the cutting edge of our mapped types support. i’m also not sure if libxml2.fx is shipping in the betas by default yet, i’ll attach a copy just in case, unzip it to ./Oxygene/Nougat/Libraries of your Oxygene install.

Thanks for that Marc.

From a different tip you gave someone else I figured out how to exclude the XML files from the build and removed the libxml2 reference, which dealt with the Sugar build issue. But now I’m having trouble referencing Sugar from a test project.

I shall try with the beta build as you suggest and see if I fare any better. Thanks again. :slight_smile:

Hmmm, 2 steps forward, 1 step back.

Cooper, Echoes and OSX build OK with the latest beta but trying to build for iOS causes VS2012 to stop working. :frowning:

define “stop working”. does it crash? if so, you get a crash stack in Event Log? Are you using the latest gamma?

You’ll have to ask Microsoft for the definition of that. :slight_smile:

All I get is a “Visual Studio has stopped working” dialog with the option to check online for a solution, close, or debug the application (i.e. VS).

The details in the event log don’t look particularly helpful, but on the off-chance that they are I shall attach the event log entry.

The error log entry resulting from the crash.

Hm, indeed, that’s not very helpful :(. Is that the only entry? Usually there’s a second one with a managed or unmanaged call stack, depending on what crashed. Can you tell what part of the build it crashes on? during the “compile” phase?

Which version of Oxygene are you using, can you u[date to the new 6.1.53 we just shipped today? Unfortunately, Sugar is still pushing mapped types to their very edge, and Carlo is constantly updating the compiler with additional support (in fact, we do have still more fixes for mapped types that will be in the next beta drop and haven’t been included in 6.1.53 ;).

I was using the latest (at the time) beta. I shall try again with the 6.1.53 build (downloading now) and post any additional info I can if the problem persists. Fingers crossed. :slight_smile:

k, if it failed with the last beta/gamma, then chances are it’ll fail with RTM too. We’ll hopefully have a beta from te next product cycle (September) up soon, i’ll see if i can push a recent internal build to your Personal Downloads folder, in the mean time.

Unfortunately no change with the new gamma. No additional information in the error log at all, no call stack.

No output from the build process other than what I believe is a warning emitted explicitly from the source, mentioning some re-write involving libxml2.

the warning is expected, yeah. have you had a chance to try the new built i out up for you in the other thread, yet?

Yes! Not an exhaustive test (it’s 11pm and I have an early start in the morning!) but with that build in my personal downloads, all sugar projects build successfully! Thank you! :slight_smile:


I’m getting the same error as the OP [Could not find .fx file “libxml2” referenced from “libSugar.fx”] and wondering if this is fixed?

I tried to download a new/updated version, but I update is showing “Could not check for updates” so unsure of how to check for fixes.

You will need the latest 8.2 beta to build the current Sugar code base. That said, for fixing the error you see, simply add a reference to libxml2 to your project.