Unable to create ClassLibrary in Visual Studio


I’m trying to evaluate Oxygene inside Visual Studio 2017 to see if I can compile some non-visual Delphi code into a .Net Core assembly.
After having installed the trial, I go to File, New, Project and I select the RemObjects Oxygen, .Net, Core category.
In there, I have the “Class library (.Net Standard)” option, which means no .Net Core for me. But anyway, as this is a trial, I select it.
It starts doing something, the bar at the bottom is blue. But after a short while, it turns purple and says that project creation failed. No details to be seen, just “failed”.

What could be the reason for this? Where can I look and what should I try?

For one, you can use then .NET Standard template to create a class library that works with both .NET and .NET Core, as standard is sort of a common denominator between the two (the reason we focused on having a template for that). For another, if you want to explicitly target .NET Core only with your library, you can simply change the TargetFramework setting in the project, after successfully creating it…

That’s curious. I’ll see if we can reproduce this here. Does it work ok for you in Water?

FWIW, does not reproduce for me in Visual Studio 2019 (I don’t have 2017 installed). Is this with the latest 2463? I’ll get one of my colleagues in here to help diagnose the issue.

For your convenience, I’m attaching an empty project you can use to get started for now; it’s already configured for .NET Core:

NetCoreClassLibrary.zip (7.4 KB)

My apologies for other inconvenience.

Thanks for confirming what I suspected with respect to .net Core support.

I did not install Water initially as I do not want to force a new IDE on my fellow developers who already use Ryder and Visual Studio.
But I installed it anyway and there, it worked but with a twist: it tells me that my trial license has expired.

I went back to VS and used the zip you posted above, and it gave me the same error message about trial license being expired

So I believe that a very similar error message is popping up somewhere in the wizard, except that it cannot be shown and ends up failing the creation process.

In the end, it appears I installed Oxygene a few months (years?) back, did not have time to use it and it’s biting me right now.

Hmm, ok. that’s not a good UX, it should have shown you something with regard to that the first time. I’ll log that for investigation.

I’ll send you a trial extension. T take it the email address I have on file for you is still good?


Thanks, I have received it, it’s working just fine now.

1 Like

Thanks, logged as bugs://83672

bugs://83672 got closed with status fixed.