Unable to install Remoting SDK in Delphi 7

Hi. I created a new Win 10 x64 VM and installed Delphi 7. I am trying to install RemObjects Remoting SDK - During install it sees Delphi 7 (and Visual Studio 2019). After install, there are no RO components or menu options in D7. I’ve tried to install manually by opening BuildPackages_D7.bpg. I am able to compile and install RemObjects_Core_D7.bpl and RemObjects_Server_D7.bpl but get an error for RemObjects_IDE_D7.bpl: Required Package RemObjects_Everwood_D7.bpl not found. I tried to manually compile/install RemObjects_Everwood_D7.dpk but get an exception whenever I close Delphi.

I did not see any log.* files in C:\Program Files (x86)\RemObjects Software.

hydra_log.xml (20.5 KB)
I installed Delphi 10.4 and was able to install RemObjects Remoting SDK - But installing RemObjects Hydra - failed. It did generate some log files
hydra_log.xml (20.5 KB)

To clarify, the D7 install failed


Can you provide other log files from C:\Program Files (x86)\RemObjects Software\Build folder, pls?
you can drop them to support@ for keeping privacy


The issue was in old bug that already was fixed: installer doesn’t add Delphi7 as a target platform for compiling under x86 platform.

Workaround: add 7 manually to -vWin32 key like:

  • single platform target (Delphi7)
@%train%  "-vWin32=7" ....
  • multi platform target (Delphi7, Delphi 10.4)
@%train%  "-vWin32=7;27" ....

where 27 - another platform

Hi Evgeny,

I am still unable to install RO and Hydra. I have tried the preview releases, and Remoting still does not get built for D7. Adding “7” to install_RO.cmd and running manually does create for D7 but on closing of D7, I get an exception. On restart of D7, most of the RO components are not checked in Packages.

I have worked > 40 hours on this: created a new VM 3 times, installed D7 and other Delphi versions multiple times, installed older versions of RO. I have no other 3rd party Delphi components installed. I have not installed anything besides Delphi and Visual Studio in my VM.

I’m never had this much trouble installed any RemObjects software before. We have been using it since at least 2010. If it would help, my manager said we could purchase a paid support ticket(s).



Interesting, I can’t reproduce locally this issue with -vWin32=7 using your versions of Remoting SDK and Hydra …
Lets continue in private