Unknown Driver UniDAC


I’ve been evaluating your trial version of Data Abstract. I wanted to setup a simple “Hello World” Client with Custom server application(your template), where I connect to Oracle database.
I’ve tried multiple drivers, but the only ones that worked on the Trial versions were ODAC, DOA, DBX, FireDAC and UniDAC.
ODAC gives me an error, when I try to Open any of the imported tables(works ok in Schema Modeler).
It’s the same for UniDAC and DOA.
DBX worked fine, but after few hours of use it started giving me errors:
driver_DBX_error driver_DBX_error2
which I couldn’t fix by reinstalling Data Abstract and trying to replace corrupted .dll with the one from one of the topic, where someone had similar issue.
The only driver that works fine is FireDAC, but it only fetches a small part of the records from the table(less than 1%). For example, UniDAC was the only driver that would fetch all the records in Schema Modeler, but wouldn’t work when used in code, because the driver was missing.
I’m not sure if my setup is incorrect, or the Trial version only provides access to the few available drivers.
I’m aware of the fact, that I need to reference in uses or drop driver component on the server module form.
Is there a way to configure FireDAC so it would fetch all the records from the table?
Can somehow install/add missing UniDAC driver?


Hi Michal

simply add the uDAUniDACDriver for UniDAC or uDAODACDriver for ODAC unit on your serverdatamodule. I don’t know if these units are there in the trial version

Best Regards


Can you send DDL for this table to support@ for investigation, pls?

as claudio.piffer said, you should add correspondent driver to your server datamodule. drivers are located in ...\Data Abstract for Delphi\Source\Drivers folder.

RemObjects.DataAbstract.Unmanaged.dll (5.8 MB) @support

That’s the .dll that gives me errors.

I’m able to locate uDAUniDACDriver.pas under ...\Data Abstract for Delphi\Source\Drivers directory but I can’t find it within the IDE.



I need sql script (i.e. DDL) for creating this table for reproducing this issue locally.

if you add this uDAUniDACDriver to your project, it will solve unknown driver UniDAC error

When I try to add uDAUniDACDriver.pas to a project it’s missing a lot of references. Is it because I’m using a Trial version? Is there an another way to add it?

The issue appears when I try to add any table(drag&drop) from Oracle DB schema.


Do you have UniDAC (this is a 3rd-party library) installed?
this file (uDAUniDACDriver.pas) is a bridge between UniDAC and DataAbstract and requires that library.

Thank you so much!
For some reasons I didn’t think that I need UniDAC driver installed to use it…
It works perfectly now.

I have one more question. Would you know whats the reason that from all the drivers only UniDAC is able to load all records from a table? I don’t add any additional options to the connection string, only these that requires me to connect to database. That’s within Schema Modeler window. I need to check other drivers, looking for a one that has the best performance.

You’ve been very helpful!


Have you checked all drivers that support Oracle, including DBX, Zeos, ADO?

Yes I did. ADO seems not to work, I’ve tried all available Aux Drivers , DBX gives me the dll error mentioned before. Zaos also loads like 1% of the table records.


Can you send DDL for this table to support@ pls?
DDL should include script for creating this table and inserting some fake data that will illustrate this issue with loading 1% of data

Edit: Schema Modeler should show only the 100 first records.