Updates


(jeremy) #1

I just noticed Fire tell me there is an update available so I tried it, but it gets stuck at this point:


I’m on .2341(on MacOS 10.14.2 beta)
This was in console:

<- Exception for UI block : Couldn't posix_spawn: error 1 at (
	0   CoreFoundation                      0x00007fff4f8e9ecd __exceptionPreprocess + 256
	1   libobjc.A.dylib                     0x00007fff7b9a0720 objc_exception_throw + 48
	2   CoreFoundation                      0x00007fff4f8e9cff +[NSException raise:format:] + 201
	3   Foundation                          0x00007fff51bdfac7 -[NSConcreteTask launchWithDictionary:error:] + 4586
	4   Fire                                0x000000010b43f68c +[__RemObjects_Elements_RTL_Process RunAsync:::::::] + 1068
	5   Fire                                0x000000010b63a612 FireAppDelegate__<>c__DisplayClass2 <doInstallUpdate>b__1$0 + 2482
	6   Fire                                0x000000010b4b541d SBLDispatch__<>c__DisplayClass1 <dispatchAsyncOnUIThread>b__0$0 + 29
	7   libdispatch.dylib                   0x00007fff7ca1fd53 _dispatch_call_block_and_release + 12
	8   libdispatch.dylib                   0x00007fff7ca20dcf _dispatch_client_callout + 8
	9   li<…>

(marc hoffman) #2

Curious, I’ll have a look and see if I can repro this. Anything else in Console?


(jeremy) #3

Nope. Just tried it again, and that is all that appears in the console, and it’s as soon as the dialog appears.


(jeremy) #4

One further bit of info - I noticed trying it again today (to see if there were any more messages - there wasn’t) that it does actually mount the DMG, as I can see it in finder, so I copied it myself to applications, but when I try to open it, I got this:
image
Not sure why that is, as the package contents all look the same as normal.
I downloaded it manually, and it was fine.


(marc hoffman) #5

hmm. can you compare the two .dmgs from the outside? are they same size and otherwise identical?


(jeremy) #6

I would if I could find the one Fire downloaded, where would it be? Finder only finds the one now I search for it.


(jeremy) #7

OK, I see that it puts it into downloads, after I moved the one I downloaded manually. As far as I can tell, they look the same with the exception that finder shows the AWS folder it came from for the manually downloaded one, whereas the one Fire got doesn’t (and it also doesn’t get to the ‘Verifying…’ before it opens, it goes straight to the error above). Get info on each side by side doesn’t show any differences.


(marc hoffman) #8

Should also be in ~/Downloads.


(marc hoffman) #9

Can you do a binary comparison in, say, Araxis Merge? That said, pretty sure it’s a corrupt download, at this stage…


(jeremy) #10

Done that, it says they are identical. I’ve done the same with the individual Fire apps as well, I can’t see anything different but something clearly is. I’ll try it on a different mac this evening.


(jeremy) #11

Exactly the same thing on my home Mac (both have Mojave). I see it download the update, mount the DMG, then it gets stuck as above. If I try and run Fire in the mounted DMG, then it also does the “can’t be opened” routine.