VCL Application Wizard Fails to build a connection string for NexusDB

I subscribed to DataAbstract because NexusDB was one of the supported database types. But when I tried to create a new VCL App using the wizard and then used the Build Connection String, I get an error saying “No Transport Protocol Defined”. I have tried adding an optional Parameter Transport=TCP - that fails also. I have tried prefixing the Server Name with a transport TCP:// and http:// this results in an error message saying those transports are not supported. I have also tried creating a full connection string manually. I have no idea how to configure DataAbstract to connect to the NexusDB Server.


Can you connect to NexusDB w/o DataAbstract? if yes, what connection string/parameters were used?

Server name:

  • ipv4://[servername@]ip-or-dns
  • np://servername[@computername]
  • embedded:
  • registered://name


  • alias://myAlias
  • path://myAliasPath

so connection string can be like

  • NexusDB?Server=embedded://localhost;Database=C:\NexusDB;
  • NexusDB?Server=ipv4://NexusDB@;Database=alias://myAlias

Hi Evgeny,
Yes, I can connect to NexusDB just fine outside of DataAbstract. I have been using NexusDB for years because it is very very fast if you access it directly.

I used your second example of a possible connection and, with a few minor tweaks I managed a connection. You are a Star - Many Thanks.

Hi Evgeny,
Can you advise me how I would specify the transport for http. Everything I try is rejected. I am trying http because the first attempt, although the connection string worked ok and the wizzard created everything, the created VCL application would not connect to the dataAbstract server. None of the tables would open although I could see all of them in the ClientDataModule.


Can you show your parameters if you are using http transport, pls?

You can drop email to support@ for keeping it in privacy