Visual Studio 2017 : "We've noticed that extension 'Oxygene Editor Extensions' is slowing typing performance"

visual-studio

(pthompson) #21

Thanks Marc. Appreciate it.


(marc hoffman) #22

I’m told at least we could reproduce the issue (so that’s good), but it’s not quite clear yet what’s causing it, more investigation will be needed.


(RemObjects) #23

bugs://81764 got closed with status fixed.


(pthompson) #24

Great this has a fixed status. Any chance of a beta build with it in ?

I’m still very much in a migration to a new development VM, so if there are rough edges to the build, not a problem.


(marc hoffman) #25

i can send you a new build later today. what’s your account name in remobjects.com, ptthompson, same as here?


(pthompson) #26

Thanks Marc. pthompson (one t). Hopefully that’ll fix things. The day is just about done here, so I’ll look to pick it up in the morning and report back.


(marc hoffman) #27

Up, on Personal Downloads.


(pthompson) #28

Thanks, I’m running the 2366 build now. Obviously only had a couple of minutes using it… It does feel better (quite a lot), but I’ve readily just seen the popup in both simple and complex projects

I’ve not had the long delays yet. I’ll give it more of a run, but would you expect to still be seeing things like the above ?


(pthompson) #29

A couple screenshots of the extension performance management dialog

and

It doesn’t feel like it’s causing a noticeable slowdown at the moment. It no longer feels like I’m trying to pull a truck whilst running uphill…


(viktoriad) #30

Hello,
At the moment Oxygene editor extension seems to show that error every starting of VS, though there is no real slowness. We have got an bug report to investigate it, but it might take some time.
Thanks in advance.


(Patrick Lanz) #31

Hello,
I had this “slow” message until the version .2353 was out.
But today, with version .2365, it’s back!
I had it twice (one for 7 seconds) when opening CC.


(pthompson) #32

Hi Patrick,

Marc provided a private build (2366) that does appear to have cleared the issue,at least for me. I was seeing the issue as significant pauses whilst typing in the editor. However I’m still seeing the “slow” messages, but it doesn’t feel like it’s actually slowing down the typing experience - more like VS being a little sensitive. I’ve also seen a couple of longer slow downs, at least one of those on the back of “building”. This screen shot shows the GUI after such a build.

Prior to private build 2366, Elements was pretty much unusable for me, even on simple projects. Now it’s perfectly usable, but I’d still like to be rid of those banner messages (I’d rather not go with the “Never show this Again” option).


(Patrick Lanz) #33

Hi P (Peter, Paul, …?)
I see this today when CC is opened or a blank line is inserted.
It seems that version .2365 has made a regression on this, because I’ve never see them last month!

For you problem, I see that you’re running in a VM. Has the VM enough memory and CPU cores?

In my case, it’s native Windows 10 and a very fast machine, so memory, disk and CPU are not issues.


(pthompson) #34

Hi Patrick,

Before .2366, I was seeing the issue pretty much constantly on anything I tried to do, CC , blank lines, anything. It was unusable really.

The VM shouldn’t be an issue, it’s a Windows 10 image with 8GB RAM and 4 processors allocated. The physical machine behind has 32GB RAM, SSD’s and a Xeon E5-2620 v4 processor.

As it stands, those messages I’m seeing are a minor annoyance, but would be good to get rid of.

(Paul)