VS2019: when a solution is opened its references are opened

Hello,
That was a bug before and was corrected, but it started again with Elements .2605.
After opening a project with all closed:


Sometimes, only the Cirrus references are opened.
Very annoying and time consuming.

Thanks, logged as bugs://85631

bugs://85631 got closed with status fixed.

Got fixed just post-.2613, but the first 2614 firehose build will have this.

1 Like

Tested this morning with Elements .2615: The references are not opened, but the projects in the solution are opened. Strange: not all are opened!

With an ASP.NET 5 application with the projects closed when VS was closed:

Thanks, logged as bugs://85772

bugs://85772 got closed with status fixed.

It has been closed, but it seems the correction is not in Elements .2621 … or the bug is still here.

Patrick,
does it still happen randomly for different projects? Does it happen always when opening your project? Here I can’t reproduce the issue any more, but I tried on simple projects only (including .Net Core created from the template).

Viktoria,
I see it on all the projects I’m working on…

If you look at the release notes for the last version, this bug is not listed, so perhaps the correction was perhaps not included in the last Elements build.

The bug could not be listed in the notes, because the change that fixed it was added for another issue. However I just checked on your project, and I see it. I will try to see what I can do, because with our logic to resolve references asynchronously in background it is really tricky.

1 Like

bugs://85772 got reopened.