Water 2287: New file added to a project does not show up

oxygene

(Michael Thuma) #1

So far I’m happy with both VS 2017 integration as well as Water.

If I create a new file of add an existeing to a project in Water (Oxygene) it’s not listed in the file node of the project tree until I close the solution and open the solution again. I also tried to modify the file, but that behavior did not change.

The environment tries to build the file. Closing Water helps to solve the issue. I found an entry in the *.sln.water.cache file. In the project file no entry could be found anymore. But I investigated the files after closing the Water IDE.

No problem at the moment.

But deleting a file leads to problems. Since the file is nor removed from the project.


(Benoît Bousquet) #2

I believe this issue was fixed in 2291. Marc will probably confirm this.


(Michael Thuma) #3

Thank you for letting me know. So I remember correctly that things worked before.


(Michael Thuma) #4

I installed the .2287 version but downloaded .2293 before into a different folder. Life ain’t easy. This special behavior is gone. Thank you.