Xcode issue

I’ve got a problem building an app that’s not been built for a few months, in Xcode (Objective-C) using DA (well, actually just the SDK). It’s saying “fatal error: ‘RemObjectsSDK’ file not found” as the #import in the _intf file is failing. I’ve noticed there has been a change in the location of these, in that there’s now an Xcode and elements folder but although I have pointed the framework at the new location:image
and changed the search paths:

it still isn’t working.

Any suggestions welcome!

As an addendum to this, I noticed on my other mac that is now updated to Catalina, that it removed the developer folder completely, so this https://docs.dataabstract.com/Cocoa/GettingStarted/installation/ is out of date and could do with an update, as to the ideal place to copy the files (since it doesn’t install any longer as it’s a DMG with all the files, rather than a package to install).

Make sure you have both Framework search path set properly, as that’s separate from the Library search path (which, together with Headers, is for .a and .dylibs).

/Developer hasn’t been there for a long while now, but one can always create it. But really, it doesnt matter where the contents of the .dmg is put these days, as long as the search paths are set to match. I’ll review the docs topic though and see if/what needs refreshing — thanx!

Does this look right then for the framework path?

I’ve reverted back to DA 9, so it was as it had been previously in terms of DA folder paths, but that’s not resolved it.
I’m too used to Fire these days :wink:

I’ve just started again here, and can replicate this. Create a new project (using the RemObjects SDK for iOS template) and add the .framework file to the frameworks, and add the framework search path (as above, the same as library) and I get the same error image

Odd. the same works if you add other frameworks the same way?

I’m not sure as that’s the only Xcode project I have and I don’t have any other frameworks (I do in fire). Does it work for you?

Perhaps you could look at the attached, just the new project created as above and see if that works for you, as that may help me find the issue in my own project.test.zip (55.2 KB)

I had the same error as you first (not unexpected, since your path doesnt match mine). I did two things:

first, I thought the icon for the framework looked off. so removed it, and readied to via the Build Phases tab by browsing for my file. That fixed the icon, but didn’t change the error.

then I manually adjusted the Framework Search Path to "/Volumes/RemObjects Data Abstract for Cocoa$(CONFIGURATION)$(EFFECTIVE_PLATFORM_NAME)" and the error went away.

however I still got

ld: Directory not found for option '-L/Developer/RemObjects Software/Bin/Debug-iphoneos'
ld: Library not found for -lRemObjectsSDK

which is odd, coz -l indicates its tying to link a static lib, NOT a framework. but in any case, adjusting the Library Search Path to "/Volumes/RemObjects Data Abstract for Cocoa$(CONFIGURATION)$(EFFECTIVE_PLATFORM_NAME)" as well, that error too went away, and the project built fine for me.

Marvellous, thank you. I repeated your steps on the test and it also works on my project. However, when I try to archive rather than just build (which I need to do as it’s got to be sent to our MDM system), it fails, as does the test, with :

ld: bitcode bundle could not be generated because ‘/Volumes/RemObjects Data Abstract for Cocoa’ was built without full bitcode. All frameworks and dylibs for bitcode must be generated from Xcode Archive or Install build file ‘/Volumes/RemObjects Data Abstract for Cocoa’ for architecture arm64

1 Like

Hm. maybe I’ll need to enable bitcode for these (I thought I had, ages ago). workaround for now, disable bitcode for the app itself, as well…

Many thanks for your support, as always.

1 Like

Glad I could help — and sorry for the delay.