Can not publish ASMX webservice

(Theo) #1

I can compile the webservice i bothe debug and release.
But when I publish the webservice, it gives an error:

Settings:

  • Publish to file system (UNC path to another machine)
  • Configuration: Release
  • Delete all existing files
  • Precompile during publishing
  • Exclude files from the App_Data folder
(marc hoffman) #2

Can you give us a more complete build log?

(Theo) #3

Just loaded the project again, and now it builds and publishes …
So I retraced my steps:

  1. Switch to debug build
  2. Rebuild
  3. Switch to Release
  4. Rebuild
  5. Publish

And the problem is back.

Build output:build_output.txt (27.8 KB)

(marc hoffman) #4

thanx. I’ve asked my colleague to have a look ASAP.

(ekaterina) #5

Thanks for the report, this issue will be reviewed under bugs://80683 from the related thread, as a general web service publishing issue.

(viktoriad) #6

Hello,
I tried to create a simple asp.net web service and reproduce the problem. It seems, with simple service and simple local publishing it works fine. Could you please heck if that problem appears for you for the particular project only, or for any newly created as well?
Thanks in advance.

(Theo) #7

Send you a PM with the project.

(viktoriad) #8

Theo, also just to confirm - you are using VS2019, correct?

(Theo) #9

No, I am using VS2017 - but Oxygene thinks this is 2019.

(viktoriad) #10

I cannot open your project in VS2017, it complains about wrong targets (VisualStudio\v16.0\WebApplications\Microsoft.WebApplication.targets). I can fix that locally to use v15.0 instead. But that was a reason why I thought you used VS2019.

(Theo) #11

Yes, to create the project, I had to make a copy of the V15 folder as V16 folder.
Otherwise I could not create the project.

And sometimes it loads without the V16 folder, but mostly not.

(Theo) #12

That was filed under: Reopened: Can not create a new ASP.Net Webservice

(Theo) #13

And one more point: I don’t have VS2019 on my machine, and I never had - not even a preview.

(marc hoffman) #14

Okay. it sounds like this issue is simply a side effect of the wrongly created project from the other thread, then — not a separate issue that needs a separate fix, correct?

(Theo) #15

Marc, I do not know.
As long as I have the V16 folder everything works - with this problem.
Without the V16 folder, I have issues.

(marc hoffman) #16

Right, but that makes sense/would be expected when your project (wrongly) references the v16 folder, no?

(Theo) #17

I am going to install the newest version, remove the V16 folder, repair this project and see if it still is an issue.

(viktoriad) #18

Theo, could you please try if the problem appears for you with the newly created web service project, with no changes in it? I cannot reproduce the problem with your project as well.
As for targets - we are working on the solution right now. There is a bug, and reinstalling will not help. But if you change the path to targets to use v15.0 locally, it might help for your problem. You will be able to open the project.

(Theo) #19

The V16 folder is a copy of the V15 folder, so that would not make sense …
And I can load it strangely …

(Theo) #20

With 2403, the problem does not appear anymore.
So this one is solved.