Cannot compile basic Silver project

(Daniel Sperl) #1

I must be overlooking something really basic — and I’m feeling really stupid having to ask this. But perhaps someone can push me in the right direction!

I just downloaded and installed “Fire” and wanted to start a basic “Silver” project for iOS, using the “Simple Application (iOS)” template and “Swift” as the default language. However, I cannot compile this project.

All references in the sidebar (except “libToffee”) have an exclamation sign on top of them, i.e. they cannot be found. The last few lines of the build output look like this:

Toffee SDK Folder found in '/Applications/ SDKs'.
E: Could not find a part of the path "/Library/Contents/version.plist".
Project 'App' failed to build.
Solution 'RemObjects.EBuild.BuildSolution' failed to build.

I have Xcode 9.2 installed (and working). Do I have to set up any paths?

Thanks in advance for any help, guys!

(marc hoffman) #2


this sounds like the build can not find Xcode. When you look at the Xcode preferences dialog shown as shown here:, do you see your current Xcode build selected in the Command Line Tools popup, or is it empty? Can you try and (re-)select the right version and see if that fixes it?

I’ll check on our end what else could cause this error, and also improve the error message…

(marc hoffman) #3


ok, I can reproduce the following:

  • if Xcode is not set at all, it should show a proper — “Xcode not installed”, or “Xcode not found at ‘x’” (if a path is set but does not exist).

  • if an Xcode path is set AND exists, but the Xcode app bundle is missing the version.plist file, I can see an error similar to yours (except mine has the full path, eg: `E: Could not find file “/Users/mh/Applications/”.

From the path you have in your message, its seems that xcode-select returns a very wrong folder path, something like /Library/Contents/Developer, as our code looks for version.plist in ../../Contents/ relative to the folder returned by xcode-select

I’d be curious to see what xcode-select --print-path shows when you run it from the command line. Also, c could you set the Build Verbosity to “Diagnostic” in Fire;'s preferences (third tab, at the top), build again, and post the full log file — that would give me a more exact error message.

In any case, I’ve further improved the error messages for the next build.

(Daniel Sperl) #4

Thanks a lot for the really fast reply, Marc! I’ll check all the things you mentioned tomorrow when I’m back at my Mac.

It could really have something to do with a wrong Xcode path. I think I first installed the Xcode command line tools (for brew), and only later Xcode itself. Perhaps that lead to something getting mixed up. I’ll check that!

I’m really impressed by what I saw and read about “Elements” so far — especially how well everything is documented, and (besides my little problem) how simple it is to set up. I’m really looking forward to experimenting with it. :smile: Keep up the great work!

(marc hoffman) #5

That could be it. will be curious to see what your settings are, and what i can do to better handle the scenario,

Glad to hear!

(Daniel Sperl) #6

That was it, exactly! When I opened up Xcode and navigated to that “Locations” tab, the dropdown for the CommandLine tools didn’t have anything selected. When I did that, compilation errors went away. W00t! So the problem was that I simply didn’t think of checking the Xcode preferences — I think I even saw that “Setting up Xcode” page yesterday, but somehow I didn’t make the connection. :roll_eyes:

Stupidly, I didn’t execute the xcode-select command before I changed the dropdown selection, so I can’t say what that output would have been like. Sorry!

Unfortunately, I’ve got more problems to report. Now I can compile, but when I launch the unchanged “Simple Application” in any of the simulators, Fire crashes. These are the “last words” of the build log:

Waiting for device to boot, current state: Shutdown
Device booted ok.
Uploading /Users/redge/Desktop/FireTestApp/bin/Debug/iOS Simulator/ to Local
Running /usr/bin/xcrun simctl install 6B7D7853-3F23-432A-9C13-DDBF265CAF43 "/Users/redge/Desktop/FireTestApp/bin/Debug/iOS Simulator/" +2018-03-14 12:14:51.140104+0100 Simulator[1737:167005] [audio] New selected input: AppleHDAEngineInput:1F,3,0,1,0:1, from deviceID: __sim__hostUseSystemDefaultDeviceUID +2018-03-14 12:14:51.140636+0100 Simulator[1737:167005] [audio] New selected output: AppleHDAEngineOutput:1F,3,0,1,1:0, from deviceID: __sim__hostUseSystemDefaultDeviceUID +2018-03-14 12:14:53.796956+0100 Simulator[1737:166994] configureKeystrokes +2018-03-14 12:14:55.868970+0100 Simulator[1737:166994] configureKeystrokes
App deployed ok.

Here another attempt, this time with diagnostic logging enabled.

Shutting down a previous Simulator instance.
Running /usr/bin/xcrun simctl shutdown 6B7D7853-3F23-432A-9C13-DDBF265CAF43
Previous Simulator instance was shut down ok.
Running /Applications/ -CurrentDeviceUDID 6B7D7853-3F23-432A-9C13-DDBF265CAF43
Waiting for device to boot. +2018-03-14 12:17:11.888646+0100 Simulator[1914:178860] Calling IOPPFGetProperty simulator_utility_clamp!
Waiting for device to boot, current state: Shutdown +2018-03-14 12:17:12.084174+0100 Simulator[1914:178886] [audio] New selected input: AppleHDAEngineInput:1F,3,0,1,0:1, from deviceID: __sim__hostUseSystemDefaultDeviceUID +2018-03-14 12:17:12.084938+0100 Simulator[1914:178886] [audio] New selected output: AppleHDAEngineOutput:1F,3,0,1,1:0, from deviceID: __sim__hostUseSystemDefaultDeviceUID
Device booted ok.
Uploading /Users/redge/Desktop/FireTestApp/bin/Debug/iOS Simulator/ to Local
Running /usr/bin/xcrun simctl install 6B7D7853-3F23-432A-9C13-DDBF265CAF43 "/Users/redge/Desktop/FireTestApp/bin/Debug/iOS Simulator/"

If it’s any help, I uploaded the crash log from the “Console” app here.

Interestingly, this happens on both of my Macs (MacBook Pro 2015, iMac 2017), both running latest macOS and Xcode.

Is there any logging mechanism that I can activate that would be of more help?

Thanks in advance for any help!

Best regards,

(marc hoffman) #7


no problem. I’ll try and repro this in a clean VM or on a Mac that hasn’t seen Xcode yet. Do you recall how you installed there Xcode command line tools? just the installer from Apple’s “More Downloads” section?

For the crash with the Simulator, are you by any chance using the very latest beta, .2263? If so, that crash is a known bug I introduced (see Fire crashes when deploying), and was fixed monday ;). If you’re on an older build, thats probably not the same problem (but not worth narrowing down, then, probably, because the code chnaged a lot for .2263), But either way, I’d like to send you a newer build later today that has the known crash fixed, so we can see if that sorts everything out for you.

What’s your user name on

Update does look like the same issue, even though this is .2255.


(jeremy) #8

Wait, you have a mac that hasn’t seen Xcode?:grin:

(marc hoffman) #9

I have last years 12" MacBook which I just got back from a screen repair and will probably set up fresh (as it’s just an outdated copy of my current main-work-machine 12" MacBook ;).

(Daniel Sperl) #10

I’m pretty sure they were downloaded and installed automatically by Homebrew setup; this must have still been with MacOS Sierra, and I installed Xcode only a few months (!) later. I didn’t need it at the time and wanted to avoid those Gigabyte-sucking updates. :stuck_out_tongue_winking_eye:

I just installed brew again on a VM; after that, the xcode-select command immediately prints a path (even without Xcode installed). So perhaps you shouldn’t spend too much time on it — might have been a glitch from my original installation. If you enhanced the error message, that’s already a great help, I’m sure.

Okay, then I’ll just wait for the update to come out! If you want me to change to a different update channel, just let me know.

Again, thanks a lot for all your swift (pun intended :wink:) help!

(marc hoffman) #11

What path does it print? I wanna see if I can detect from that if its a valid Xcode or just a command line tools install, and provide a better message.

I’ll post a new internal build for you in, in about an hour or two.

any time!

(Daniel Sperl) #12


$xcode-select --print-path

You’re right, that should be easy to recognize! :smile:

Thanks, I’ll try that out when it’s ready and will post my results here.


(marc hoffman) #13

Build is up.

(Daniel Sperl) #14

That fixed it — fantastic! Finally, running and debugging code. It’s magic! :smile:

Thanks again!

Running on the device probably fails because of this issue right now, but that’s not a problem for my current use-case.


(marc hoffman) #15


hmm. that should be the same issue. that still crashes for you, even with the new build?

(Daniel Sperl) #16

Oh! Hm, yes — just tried again, definitely with build 2264. Device crashes, simulator works. Is there any way I can give you a useful log file?

Here’s the build log from directly before the crash. Lots of warnings — perhaps that helps in some way.

(marc hoffman) #17

Yep, confirmed (see other thread). it was a similar problem, but different. Shame on me for only retesting the Simulator version, after the previous compiler fix ;). I’ve worked around noe and am uploading a new build, .2264B for you. should be up in 20 or so, same place.

thanx for reporting this, else this crash would probably have made it into Friday’s official build :wink:

(Daniel Sperl) #18

I’m glad to hear that — and happy I could help! :smile:

(marc hoffman) #19

Up, sorry took a bit longer, slow upload speed form the :desert_island: this afternoon :(.

(Daniel Sperl) #20

That did the trick! Now everything seems to be working perfectly. Thanks a lot for your efforts, Marc! :smile: