Code-first server never compiles


(marc hoffman) #42

Checking your license files now,

  • ImportedLicense0.license only has age-old licenses (think 2015 and before).
  • Download_ndelic.licenseslooks valid. your RO and DA license expired 2018-09-26, and the file itself is newer (2018-11-28) so this file should work for any version of RO/DA shipped before September 26.

I now replaced my local licenses with yours (and disabled my login) and building your testa app, for me too fails with

E:                Error while processing licenses: System.ComponentModel.LicenseException: No valid license has been found for the type RemObjects.SDK.Server.ServerChannel

that is good, because I have the newer version installed.

Now I installed the 9.4 binaries and I can reproduce the hang. So that’s a good first step. Now we need to debug :(.


(marc hoffman) #43

Follow=up: it’s weird. that build doesnt like your license file at all, nor does it like the license extension I generated for you. It likes my own license fine, and I cannot see why. I’ll need to have @antonk debug this tomorrow, with this extra info.

That said, did this build of RO/DA ever work for you in the past? If so, what changed? The new Fire version (and it conjoining a newer RO/Da) was a complete red herring, it has nothing to do do with this this fails. So I wonder how this ever worked for you…


(ndelic) #44

I don’t know. The last time I compiled the server in Fire was sometime in July and I don’t remember which version of Fire or RODA I had then. I’m guessing both were beta as I updated them sporadically, not on each new version. I did most of the work in Visual Studio since then because I worked on DevExpress web app in combination with RODA server.


(marc hoffman) #45

Ok, this is embarrassing. can you rename/copy “Download_ndelic.licenses” to “Download_ndelic.license”, without the “s”?


(ndelic) #46

I did, but it’s still stuck generating resources.


(marc hoffman) #47

Hmm. That’s very weird because that’s exactly what the problem was, and changing the name does fix it for me. Are you sure that everything else is still proper in place and not m iced up from previous testing? i.e. is it referencing the right 9.4 dlls, is it the right license file?


(ndelic) #48

This is from the log:

Reference "RemObjects.DataAbstract.Server, Version=9.4.109.1377, Culture=neutral, PublicKeyToken=3df3cad1b7aa5098" was compiled with an older version of the compiler and should not be used with the current version

So I guess references are ok?

How can I be sure it’s using the right license? Delete all of them and then import Download_ndelic.license again from Fire?


(marc hoffman) #49

Delete em all, redownload in Fire, and then rename the file to have .license, no S, as extension.


(ndelic) #50

I did exactly as you described. Still stuck. :frowning:


(marc hoffman) #51

can I TeamView into your system? (I could do either right now, or in 2-3h)


(ndelic) #52

check email