RemObjects Hydra - 6.0.0.1191_beta.exe cannot compile Island Example


(Carsten Bartholomae) #1

Hi,
i installed the latest Hydra Beta, because in the latest stable version, the island non-visual plugin does not complile .
With the latest version either. See screenshoot.

KR
CBL


(marc hoffman) #3

What version of Elements are you using?


(Carsten Bartholomae) #4

I am currently using 10.0.0.2313. The same issue occurs with 10.0.0.2305


(EvgenyK) #5

Hi,

I can’t reproduce above error.
can you check to what location is referenced Hydra?
it should to C:\Program Files (x86)\RemObjects Software\Hydra for Island\Bin\Windows\i386\Hydra.fx

another issue with this sample:
we have refactored Island and nowadays ToLPCWSTR was assemble declaration, so add to this sample this extension:

extension method String.ToLPCWSTR: rtl.LPCWSTR; public;
begin
  if String.IsNullOrEmpty(self) then exit nil;
  var arr := ToCharArray(true);
  exit rtl.LPCWSTR(@arr[0]);
end;

(Carsten Bartholomae) #6

Hi,
removing and reinstalling the beat did at least resolve the reference issues.
Building the project directly after loading produces the following output:

when adding the extension at the end of the file:

Rebuilding the project produces this output:

not very promising,


(EvgenyK) #7

can you try to use newest element build, like 10.0.0.2319?


(Carsten Bartholomae) #8

Hi,
i tested with Elements 10.0.0.2319, still not possible to compile.
Please provide me with an exmaple, that can be compiled successfully.
Actually Elements works with all Examples without any Errors, except that the Hydra for Island Example cannot be compiled successfully.


(marc hoffman) #9

Same linker errors, still, with .2319/.2321?


(Carsten Bartholomae) #10

same Errorlist as above


(EvgenyK) #11

if you recompiled ...\Hydra for Island\Source\Hydra.sln manually and specified Hydra.elements as reference instead of precompiled Hydra.fx, would it work?


(marc hoffman) #12

Hmm, I can not reproduce this, latest Elements (not much changed since .232)1 and latest Hydra… Can I send you a newer Hydra build JIC?


(Carsten Bartholomae) #13

Hi,
i could try to compile the source and adjust the reference.
Unfortunately, the folder does not contain the maintioned Hydra.sln file:


(marc hoffman) #14

just open Hydra.elements. But first, try the new build I uploaded for you?


(Carsten Bartholomae) #15

HI,
with this build, the plugin was compiled successfully without errors and warnings.
Great.
But when copying the *.dll and *.fx into the Mixed Demo \bin… Folder, the oxygene host does not regognize the Island Plugin DLL.
The VCLHost and FMXHost neither


(marc hoffman) #16

Glad to hear

I’ll need to leave that one to Eugene to answer…


(EvgenyK) #17

these samples loads only .dll plugins:

procedure TMainForm.FormCreate(Sender: TObject);
begin
  //Load all plugin modules that match search pattern
  ModuleManager.LoadModules('*Plugin*.dll');
  //Show available plugin in a combo box
  ListPlugins;
end;

if you want to load island plugin into those hosts, add code into FormCreate method like

  ModuleManager.LoadModules('*Plugin*.fx');

(Carsten Bartholomae) #18

Please update the Mixed Mode Example.
If you offer Island Plugins, than your Demos/Exmaples should recognize and load/use them


(EvgenyK) #19

The Mixed Mode sample works with visual plugins only.
Island supports non-visual plugins only.


(Carsten Bartholomae) #20

Thank you for the hint.
Nevertheless, which out-of-the-box example can load and show Island Plug-ins.
i tried the Delphi Demo (FMXhost and VCLhost) which allows loading Visual and Non-Visual Plugins.
But could not load Island Plugins as well.


(EvgenyK) #21

just add the same line into those hosts